cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
delta
Regular Visitor

On-premises Gateway Installation Error

I am having trouble installing the On-premises Gateway on Windows Server 2008 SP2 and Framework 4.5. I am running the installation as Admin, but getting a generic error message. 

 

Capture.PNG

The failure message from the error log is below. All searches for EgwComponents failues have just talked about running as Admin. Any ideas would be greatly appreciated.

 

 

.
.
.
MSI (s) (7C:E8) [13:58:12:928]: Note: 1: 1708 
MSI (s) (7C:E8) [13:58:12:928]: Product: EgwComponents -- Installation failed.

MSI (s) (7C:E8) [13:58:12:928]: Windows Installer installed the product. Product Name: EgwComponents. Product Version: 1.15.6170.1. Product Language: 1033. Installation success or error status: 1603.

MSI (s) (7C:E8) [13:58:12:931]: Deferring clean up of packages/files, if any exist
MSI (s) (7C:E8) [13:58:12:931]: MainEngineThread is returning 1603
MSI (s) (7C:88) [13:58:12:931]: RESTART MANAGER: Session closed.
MSI (s) (7C:88) [13:58:12:931]: No System Restore sequence number for this installation.
=== Logging stopped: 1/10/2017  13:58:12 ===
MSI (s) (7C:88) [13:58:12:932]: User policy value 'DisableRollback' is 0
MSI (s) (7C:88) [13:58:12:932]: Machine policy value 'DisableRollback' is 0
MSI (s) (7C:88) [13:58:12:932]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (7C:88) [13:58:12:932]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (7C:88) [13:58:12:933]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2 
MSI (s) (7C:88) [13:58:12:933]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (7C:88) [13:58:12:933]: Restoring environment variables
MSI (s) (7C:88) [13:58:12:935]: Destroying RemoteAPI object.
MSI (s) (7C:A4) [13:58:12:935]: Custom Action Manager thread ending.
MSI (c) (70:E0) [13:58:12:938]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (70:E0) [13:58:12:938]: MainEngineThread is returning 1603

 

 

8 REPLIES 8
Panteras01
Regular Visitor

I've been experiencing the exact same problem when trying to install and have tried the run as an Administrator and keep getting the error and the installation doesn't finish.

georgelehmann
New Member

I had the same 1603 error.

 

You may want to right click the file Gateway Install.exe and choose "Run as Administrator".  I am admin on my computer, however I did choose "Run as Administrator", it ran and asked me during a trouble-shooting step if I wanted to choose "Compatibility" for Windows XP (Service Pack 2).  It worked.

 

My operating system is Windows 7 Professional, Service Pack 1.

Run as admin resloved my problem. 

@delta Looks like a perms issue. Looking up the 1603 error leads me to this support page. Check the things outlined there to see if that resolves your issue.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Thanks for the quick reply Eno. However, none of the items in the cause list apply to our situation.

 

 I forgot to mention in my first post that this is a fresh install. Neither Gateway or Power BI has ever been installed on this machine.

@delta hmm. Can't say for sure, here is another scenerio to look into (Different product, but seemed to apply) It's not necessarily a "Power BI" thing, it seems that its an environmental issue that is killing the install of a new service.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Thank you Eno for trying to help. I ran multiple repairs and Windows Updates on the server hoping to fix whatever was wrong with the installer. Nothing gets it past that errror.

 

I've given up trying to install it on 2008 and moved it to 2016. That server didn't give me an error.

Hi @delta,

 

From your description, the issue should be related to machine specific. You can create a support ticket to get dedicated if you want. 

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
May 23 2022 epsiode 5 without aka link.jpg

The Power BI Community Show

Welcome to the Power BI Community Show! Jeroen ter Heerdt talks about the importance of Data Modeling.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

Power BI Dev Camp Session 22 with aka link 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!

Power BI Release May 2022 768x460.png

Check it out!

Click here to read more about the May 2022 updates!