cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
FunDeckHermit
Helper I
Helper I

Missing log files from On-Premises Data Gateway

Hello,

I am trying to troubleshoot my connection and downloaded the log file. 

The log file only contains two files:

 

  1. Gateway20180423.000000000
  2. GatewayProperties

23th of April was the first date I installed the Gateway. I would have expected more files. 

I restarted the server gateway multiple times today. 

 

 

1 ACCEPTED SOLUTION
v-yuezhe-msft
Microsoft
Microsoft

@FunDeckHermit,

Do you directly export log from gateway configurator?

1.PNG

If so, please go to the following folders and check if there are additional log files.

Configuration logs

%localappdata%\Microsoft\On-premises Data Gateway


On-premises data gateway service logs

C:\Users\PBIEgwService\AppData\Local\Microsoft\On-premises Data Gateway



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-yuezhe-msft
Microsoft
Microsoft

@FunDeckHermit,

Do you directly export log from gateway configurator?

1.PNG

If so, please go to the following folders and check if there are additional log files.

Configuration logs

%localappdata%\Microsoft\On-premises Data Gateway


On-premises data gateway service logs

C:\Users\PBIEgwService\AppData\Local\Microsoft\On-premises Data Gateway



Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I am using an On-premise Gateway(personal mode).

 

I cannot find any *.zip file under the "%localappdata%\Microsoft\On-premises Data Gateway" 

or "%localappdata%\Microsoft\On-premises Data Gateway (personal mode)"

or "C:\Users\PBIEgwService\AppData\Local\Microsoft\On-premises Data Gateway"

after directly exporting log from App UI.

 

Looks there are only some *.log files under the "C:\Users\PBIEgwService\AppData\Local\Microsoft\On-premises Data Gateway". Are those just the exported logs generated by clicking 'Export Logs' link on App UI?   

 

image.png

 

Hello Lydia,

I did export directly using the gateway configurator.

This created a .ZIP file with only two files. 

 

The "%localappdata%\Microsoft\On-premises Data Gateway" folder contains the missing logs:

Capture16.PNG

Thanks for your assistance

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors