Showing results for 
Search instead for 
Did you mean: 
Advocate I
Advocate I

Long time "Evaluating..." for no apparent reason during data import. Can it be made faster?

I am connecting to a SQL database through a Stored Procedure. As far as I know, there is no intelligence that needs to be applied during the query. It should simply ask SQL to run the sproc, and gather the results.


However, for some reason, PBI stays a good two minutes or more, simply "evaluating". What is it doing exactly? Is there any way this can be accelerated, so that it gets to the date faster?


I've read about folding, but since this is running an sproc, I don't think it applies.


Thanks in advance for any pointers.

Regular Visitor

I have faced very similar issues using PowerBI. When I try to see what active sessions are running on the database, it doesn't show any PowerBI sessions. When I executed a profile and traced all the queries, it was observed that PowerBI is sending the same SQL query millions and zillions of time to the server. My query was finishing within a second but PowerBI was stuck in "Evaluating" mode becuase it was possibly executing the same query again and again. Possible PowerBI bug? 


Once or twice when I cancel the PowerBi interface to stop applying the changes and try again it goes through successfully quickly and loads the data in PowerBI. Just FYI, I was trying all this in Direct Query mode.

Helper I
Helper I



I am facing the same issue over a file which up until yesterday night was working just fine. The "evaluating" phease was progressing very smoothly. Then suddenly now it has stopped responding. Please help

Advocate II
Advocate II

Please help, 


I run into this problem frequently, Particularly when I have Merged or Appended queries in the query editor. Currently I am hitting this issue solely on one of the query refreshes in my file.  I have seen this happen when I connect to both SQL sources as well as in this current case where I am only accesing local Excel and CSV files. 


When trying to refresh 5 of 6 evaluate very quickly and then the last gets stuck.  This can get stuck for a long time, I have waited for over 10 minutes at different times just to check. I will usually cancel the refresh and evaluate manually in the following way. 


Evaluating on refresh


I will then go into the Query Editor where I see the following


Query Failure


After clicking the RETRY button, The query evaluates very quickly and all of the intended data then appears.


Evaluation completes after selecting "Retry"


Immediately following this Step I can go right back to Refresh all data in the report and it refreshes as it it supposed to. Loading Data to model

Data Refreshes and Loads

Not applicable

This hack worked like a charm, but I searched for this problem only after waiting for a couple of hours. Microsoft seriously needs to look into this issue. Sometimes it gets dead stuck on "Evaluating". 

Well its abeen about ayear since I created this post and I still have same issues. I doubt they are going to be fixing it soon....Smiley Sad



I have this exact same problem. I many cases, where I have some query editing going on in the Query Editor, the last table will hang on "Evaluating" and takes multiple minutes to go by. Frustrating and messes up my gainz! I have DocumentDB Data and static xls-data. But I have an appended table as well (azure+static xls). Query Editor should be made of hardened steel and not from cotton candy and be able to handle this kind of basic stuff...


How to resolve? Is this just because of the Query Folding?



30112017 query folding..PNG


My Ram usage is quite epic. Please fix this Microsoft. I am doing basic data handling in the background and this cannot cope? Where's my tableau desktop...


30112017 query editor ram usage epic.PNG


How much data is it pulling in?

How fast does it run in SSMS?

As a start - try disabling the following properties: File -> Options and Settings -> Options -> Data Load - > "Import relationships from data sources" and "Autodetect new relationships after data is loaded"

Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Thank you very much for the comments. I have just tried disabling these options, and unfortunately it doesn't seem to make any difference.


I am pulling in about 100k records.


So next steps. How long does the stored procedure take to run in SSMS?

Are you using any table variables or temp tables in the procedure?

And have you verified that the user has access to execute stored procedures in the database?



Looking for more Power BI tips, tricks & tools? Check out the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

I am also very curious about what exactly Power BI does in that step.

I also have a couple of reports that take way too long for that step while getting the on-premise data is actually pretty fast. So I wonder what I can do to optimize the queries behind it. 

Any insight into this would be greatly appreciated.

Did you ever find out the cause? I'm running into this same issue. It seemed to start happening after an unexpected power loss on my PC. I restored from a recovered file and this seems to have been happening ever since!

Helpful resources


Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors