cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rzavgazaryan
Helper IV
Helper IV

I can refresh my Power Query Excel File (living in SharePoint), but my coworker cannot (SQL)

Hi all -

I have a excel file that lives in our team's SharePoint folder. I have connected to a SQL server that my teammates and I have access to. I query a small dataset, did a few transformations, and loaded the table to a sheet.

When I hit refresh, it takes no more than 30 seconds for everything to refresh, and I'm all set.

Now when I ask my coworker to go to the same SharePoint folder, and refresh the dataset, he gets an error which says: "We were unable to refresh one or more data connections in this workbook. The following connections failed to refresh:"

rzavgazaryan_0-1643045329068.png

 

All the tables loaded are from the same database.. what could be going wrong? I always have issues with other people having to refreshing my Power Query connections in an excel file. Would appreciate any help here. Thanks!


1 ACCEPTED SOLUTION
KNP
Super User
Super User

Could you ask your colleague to open the file and go to Data>>Get Data>>Data Source Settings

KNP_3-1643055793475.png

 

Then edit the permissions...

KNP_1-1643055652092.png

Then change these as required...

KNP_2-1643055688646.png

 

Hopefully this helps.

If not, I'd be confirming the permissions at the database level.

 

Have I solved your problem?
Please click Accept as Solution so I don't keep coming back to this post, oh yeah, others may find it useful also ;).
chrome-9xf-Zagzel-B

If you found this post helpful, please give Kudos.
It gives me a sense of instant gratification and, if you give me Kudos enough times, magical unicorns will appear on your screen.
If you find my signature vaguely amusing, please give Kudos.
KIfp67uy-Sr
Proud to be a Super User!PBI-Super-User-Rank-30x30-1x

View solution in original post

1 REPLY 1
KNP
Super User
Super User

Could you ask your colleague to open the file and go to Data>>Get Data>>Data Source Settings

KNP_3-1643055793475.png

 

Then edit the permissions...

KNP_1-1643055652092.png

Then change these as required...

KNP_2-1643055688646.png

 

Hopefully this helps.

If not, I'd be confirming the permissions at the database level.

 

Have I solved your problem?
Please click Accept as Solution so I don't keep coming back to this post, oh yeah, others may find it useful also ;).
chrome-9xf-Zagzel-B

If you found this post helpful, please give Kudos.
It gives me a sense of instant gratification and, if you give me Kudos enough times, magical unicorns will appear on your screen.
If you find my signature vaguely amusing, please give Kudos.
KIfp67uy-Sr
Proud to be a Super User!PBI-Super-User-Rank-30x30-1x

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors