cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PBInJelly1
Regular Visitor

Help With Column Disappearing on Combine and Transform

Hi Everyone,

 

I'm currently creating a table using multiple excel files inside a folder as a source. These excel files all have the same number of columns except 1 of them, which has an extra column called "Column ABC". Column ABC is being removed from the final table and I need it to show up. Does anyone have suggestions for this? 

 

combine.PNG

Thank you, 

 

PBInJelly1

1 ACCEPTED SOLUTION
watkinnc
Super User
Super User

The easiest way to stop this is to make sure that before you expand the tables, the table with the most columns at the top. Ideally this would be your "sample file" that you do your pre-combine transforms. First get the tables ordered how you need them, by created date or whatever. Then add an index column to keep that sort order. Then, use the Add Column GUI function to type:

each Table.ColumnCount([TheNameOfYourTableColumn])

Now, sort the ColumnCount column descending. Now when you expand the tables, all of your columns will be there, and the only nulls will be in the last column. If you run into a missing column error, add the MissingField.Ignore parameter as the last parameter of Table.ExpandTableColumn.

 

--Nate


I’m usually answering from my phone, which means the results are visualized only in my mind. You’ll need to use my answer to know that it works—but it will work!!

View solution in original post

3 REPLIES 3
watkinnc
Super User
Super User

The easiest way to stop this is to make sure that before you expand the tables, the table with the most columns at the top. Ideally this would be your "sample file" that you do your pre-combine transforms. First get the tables ordered how you need them, by created date or whatever. Then add an index column to keep that sort order. Then, use the Add Column GUI function to type:

each Table.ColumnCount([TheNameOfYourTableColumn])

Now, sort the ColumnCount column descending. Now when you expand the tables, all of your columns will be there, and the only nulls will be in the last column. If you run into a missing column error, add the MissingField.Ignore parameter as the last parameter of Table.ExpandTableColumn.

 

--Nate


I’m usually answering from my phone, which means the results are visualized only in my mind. You’ll need to use my answer to know that it works—but it will work!!

View solution in original post

goncalogeraldes
Solution Supplier
Solution Supplier

Hello, could you provide the Advanced Query Editor steps? It may help to understand what is happening the combine step. Change all sensitive information if needed!

 

In the meantime, maybe these to videos can help you:

 

https://www.youtube.com/watch?v=nG-iIdb19Ng

https://www.youtube.com/watch?v=wKglApDFMog

 

*edited to removed advanced script*

 

Update - I found the solution in the video that you sent (see image). However, now that I added a list of column headers, all values have changed to null. This did not happen in the video. Do you have any ideas why it did this? 

 

listofcolumns.PNG

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors