cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Google sheet data download suddenly stopped working

I use data from google sheets in a number of our apps and as of this morning I got the same error message that they weren't automatically updated in Service. After further inspection (in PBI desktop) I found out that these connection don't download data they are supposed to but some gibberish in html (I attach the picture).

1) I tried the links and when I put them in browser they work correctly as they download what PBI is supposed to but doesn't. So clearly the problem is on the PBI side.

2) I cleared the cache and permissions but with no result

 

I need an urgent help as I am clueless and almost all of my business relies on these data downloads, thank you!Screenshot 2020-11-18 092904.png

1 ACCEPTED SOLUTION
New Member

I have since found out that google have added something.


To resolve this, go to the google doc, select file, click on share.
On the Get Link section, click on "Change to anyone with the link".

 

All should be good from there.

View solution in original post

5 REPLIES 5
Helper I
Helper I

Thank you all for the reply. As the first solution I received was to change the download links, I spent whole day on rewriting them for every app that we have. This worked but it worked only beacuse I did the second step ->

I found out that all that I needed to do was what @NelxUK was saying, which is only to switch in Share button Get Link section to "Change to anyone with the link".

Until now I don't know the difference between publicizing the link to the web and writing the link in a manner suggested by @V-pazhen-msft. When I found out that I don't have to rewrite whole link I only enabled in google sheet sharing with anyone with the link and it worked as well. So I guess both options will work as long as you have it turned on in google sheet. Thank you everyone for your help!

New Member

I have since found out that google have added something.


To resolve this, go to the google doc, select file, click on share.
On the Get Link section, click on "Change to anyone with the link".

 

All should be good from there.

View solution in original post

Community Support
Community Support

@michael163 

 

The easiest way is to Get Data / From Web, then enter the URL to your google sheet, you must add "&output=xls" on the end, e.g.

http://spreadsheets.google.com/pub?key=r1hlZB_n1rpXTij11Kw7lTQ&output=xls


Paul Zheng _ Community Support Team
If this post helps, please Accept it as the solution to help the other members find it more quickly.

Helper I
Helper I

i have the exact same problem. (i am in SR too)

Helper I
Helper I

So I moved further with the solution, however I still dont have it. The PowerBI started treating my google sheet data as html (thus <doctype html>) instead of csv even though there is this start of script in advanced editor

Source = Csv.Document(Web.Contents("https://docs.go........."

I still cant figure out what has changed and causes this.

Helpful resources

Announcements
secondImage

Congratulations!

We are excited to announce the Power BI Super Users!

Wave Release 2

Check out the updates in Power BI.

Overview of Power BI 2020 release wave 2!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors