cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Error fetching JSON from AzureDevOps REST

I'm attempting to fetch data from Azure DevOps REST and getting the following error.  I've seen other threads on this, but none have bene answered.

 

When I save the JSON locally and parse it, it works fine, but it won't fetch data from the web service.

 

DataFormat.Error: We found extra characters at teh end of JSON input.

Details:

    Value=

    Position=4

3 REPLIES 3
Resident Rockstar
Resident Rockstar

Hi @Dustin ,

Do you get the data with Web connector in Power BI Desktop?

If it is convenient, could you share your sample JSON code and your error message screenshot so that we could help further on it?

Best Regards,

Cherry

 

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

What I'm getting back is HTML - a page for Azure signin.  I'm trying to figure out how to authenticate using a PAT so I can call DevOps REST.

I'm getting exactly the same error. At present I've not found any way around the issue. Any help is going to be greatly appreciated.

Helpful resources

Announcements
secondImage

Happy New Year from Power BI

This is a must watch for a message from Power BI!

December Update

Check it Out!

Click here to read more about the December 2020 Updates!

Community Blog

Check it Out!

Click here to read the latest blog and learn more about contributing to the Power BI blog!

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Mark your calendars and join us for our next Power BI Dev Camp!.

Top Solution Authors
Top Kudoed Authors