cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Samppooni
Regular Visitor

Error connecting SSAS multidimensional data source (preview feature: explore live)

Solved with upgrading to enterprise edition. Standard edition is not supported with explore live from multidimensional data source.

 

Please vote for adding standard edition to supported list: https://ideas.powerbi.com/forums/265200-power-bi-ideas/suggestions/11331360-connect-multidimensional...

 

Original problem:

 

Testing on system running

Windows Server 2012 R2 with latest patches

and 

SQL Server 2014 with SP1 x64 with CU3

  • DB Engine
  • Integration Services
  • Analysis Services

Analysis services language settings:

SSASLangSet.png

System language settings:

OSLangSet1.pngOSLangSet2.pngOSLangSet3.png

 

Latest Power BI Desktop x64 English installed with preview features enabled:

PDSet1.png

 

When adding datasource/connection to SSAS multidimensional database's cube with "Explore live" -setting:

PDCon1.pngPDCon2.png

 

Will receive the following error:

PDConErr1.png

 

And the "Copy Details" containing info:

Spoiler
Error Message:

Couldn't load the model schema.

Stack Trace:



Invocation Stack Trace:



Couldn't load the schema for the database model
Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.

Error details
rsCannotRetrieveModel: An error occurred while loading the model for the item or data source 'EntityDataSource'. Verify that the connection information is correct and that you have permissions to access the data source.

Stack trace
Microsoft.ReportingServices.Diagnostics.Utilities.CannotRetrieveModelException: An error occurred while loading the model for the item or data source 'EntityDataSource'. Verify that the connection information is correct and that you have permissions to access the data source. ---> Microsoft.AnalysisServices.AdomdClient.AdomdErrorResponseException: Errors related to feature availability and configuration: The 'Tabular View' feature is not included in the '64 Bit Standard' edition of Analysis Services.

Activity ID
40c59029-803e-48e9-8273-ad9fae33f7ce

Time
Fri Dec 11 2015 01:42:38 GMT+0200 (FLE Standard Time)

Version
2.29.4217.341 (PBIDesktop)

And Event Viewer Application Log also showing:

Spoiler
The description for Event ID 25 from source MSOLAP$AnalysisServicesWorkspace405352735 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

msmdsrvi.rll
1035

Maybe this is some sort of language mismatch problem? I have tried to change every language setting to en-US but no luck, always the same error.

 

1035 defines Finnish language whereas 1033 is English(US).

13 REPLIES 13
Samppooni
Regular Visitor

Upgraded the edition from standard to enterprise. Live connection works, no news there.

 

Standard is then not supported, case closed.

 

Please vote for adding standard edition to supported list: https://ideas.powerbi.com/forums/265200-power-bi-ideas/suggestions/11331360-connect-multidimensional...

nax123
New Member

Error indicates an issue with SQL version. I tried on different servers and got the same error when using SQL Std edition, everything worked on SQL Ent edition servers. Is there a version limitation on this feature? Anyone managed to get it working on SQL Std?

I hope Microsoft clarifies the edition requirement -from PowerBi Eneterprise Gateway announcement it is clear that DAX MD is required which is not part of standard edition. Also there is no support for DAX MD for pre SQL 2012? As most of our customers are still running 2008 R2 Std, it would be great to know if there will be live connectivity support for this version (and std edition support for later cersions), otherwise PowerBI offer would need to start with upgrade request.

 

DAX MD is supported since SQL Server 2012 SP1 CU4 and works on BI Edition and above

See https://msdn.microsoft.com/en-us/library/cc645993(v=sql.120).aspx

DAX MD is supported since SQL Server 2012 SP1 CU4 and works on BI Edition and above

See https://msdn.microsoft.com/en-us/library/cc645993(v=sql.120).aspx

We are running SQL Server 2014 Standard.

Do you mean you have it up and running on 2014 std?

Sorry, no, I don't have it running on sql server 2014 std.

I'm waiting someone to confirm that the Standard version works. I haven't received any confirmations yet.

 

Enterprise version does work, as some has commented and I have heard this from another source also.

You need BI Ed. min.

Are there any updates to this? I have the Standard edition and am receiving the same errors.

 

Regards,

 

John

Bjoern
Responsive Resident
Responsive Resident

I am stupid; sorry.

So I have understood the "or later versions" -definition wrong then. If this is the case we have to redo the SQL Server installation.

 

I hope the documentation would somehow emphasize on the fact that newer SQL Server (2014) is not supported. What about the 2016 version which is just around the corner?

 

Bjoern edited his answer which made my reply moot. It seems he misread my original post.I'm still leaving my reply but I'm presuming SQL Server 2014 is supported.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

July 2021 Update 768x460.png

Check it out!

Click here to read more about the July 2021 Updates

Top Solution Authors
Top Kudoed Authors