cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bogdans Regular Visitor
Regular Visitor

Error accessing SharePoint List from Power BI Desktop: "Access to the resource is forbidden."

Hello all,

 

I am trying to import data from a SharePoint list and I'm getting the following error:

 

image.pngI've made sure the URL is the root one, I've made sure I'm logged in to my Power BI account which has a license, I've made sure the SharePoint list is accessible to me as I'm the owner of it, I've tried importing the data from a different computer with a different account and it still didn't work.

 

Is there anything else I should try?

 

Thank you.

 

1 ACCEPTED SOLUTION

Accepted Solutions
bogdans Regular Visitor
Regular Visitor

Re: Error accessing SharePoint List from Power BI Desktop: "Access to the resource is forbidden

I've had a colleague help me fix it. The way I did it was go into Power BI Desktop version>File>Options and settings>Data source settings. See image below

 

image.png

 

There I chose "Edit Permissions" and opened up a new window:

 


image.png

I pressed "Edit" and then selected the bottom option in the left side to connect with my organization credentials. Before I used the Anonymous option to connect and seems like that was the issue. 

 


image.png

The login is not the same for me after I connected but it should look similar to this. Thought I'd post this for future reference.

View solution in original post

1 REPLY 1
bogdans Regular Visitor
Regular Visitor

Re: Error accessing SharePoint List from Power BI Desktop: "Access to the resource is forbidden

I've had a colleague help me fix it. The way I did it was go into Power BI Desktop version>File>Options and settings>Data source settings. See image below

 

image.png

 

There I chose "Edit Permissions" and opened up a new window:

 


image.png

I pressed "Edit" and then selected the bottom option in the left side to connect with my organization credentials. Before I used the Anonymous option to connect and seems like that was the issue. 

 


image.png

The login is not the same for me after I connected but it should look similar to this. Thought I'd post this for future reference.

View solution in original post

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (4,112)