cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Error 400 - Odata connection error

Hello all,

 

We have a connection to our Navision database with OData using Web Services.

However since last week we're getting the following error:

Error 400 - Bad Request OData.png

The used URL is:

http://10.0.0.XX:7048/LIVE/OData/Company('[Navision Company code]%20-%20XX%20[Company city]')/GL_export

Also tried a shortened and expanded URL

Trying to connect via Windows credentials.

 

We tried many things including restarting the server, compiling the data but all didn't help.

 

Any help would be greatly appreciated as we can't continue implementing Power BI right now.

 

Thank you.

 

Chris

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Hello,

 

Problem was with Navision.

 

We make the Odata connection using web services.

In these web services we made both a query and a page which directed to the same data.

 

This created a conflict which caused an error.

That's why first everything worked fine at first and then after some weeks not anymore.

 

So solution was simply to remove the page.

 

Thank you.

View solution in original post

3 REPLIES 3
Microsoft
Microsoft

@cgeraeds,

What is the result if you connect to the OData URL in Excel? And how about replacing the IP address with server name in your URL?

Regards,
Lydia

Community Support Team _ Lydia Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hello Lydia @v-yuezhe-msft,

 

In Excel I receive the same error message:

image.png

 

Using the server name doesn't let me log in, it doesn't recognize my Windows credentials.

 

Any other solutions?

 

Kind Regards,

Chris

Highlighted
Helper I
Helper I

Hello,

 

Problem was with Navision.

 

We make the Odata connection using web services.

In these web services we made both a query and a page which directed to the same data.

 

This created a conflict which caused an error.

That's why first everything worked fine at first and then after some weeks not anymore.

 

So solution was simply to remove the page.

 

Thank you.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors