cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PauSempere
New Member

Error 400 Bad Request when publishing a PBIX file

Hi folks, 

 

using the last versions of Power BI and Enterprise Gateway I am trying to publish a PBIX file connecting to a on-premises SSAS server, but I am getting an Error 400 (Bad Request) when doing so. In the detailed error description I found this error

 

HttpStatusCode
BadRequest

ErrorDetails
{"error":{"code":"ModelHasNoPowerBIDMMoniker","pbi.error":{"code":"ModelHasNoPowerBIDMMoniker","parameters":{},"details":[]}}}

ErrorCode
ModelHasNoPowerBIDMMoniker

 

The gateway works correctly though, and I can see live data from the portal when I upload a new PBIX file with the same SSAS connection and any graph is added. 

 

I have not found any extra info about this error, any ideas about what can it be? 

 

Thank you in advance. 

 

Pau Sempere

1 ACCEPTED SOLUTION

@PauSempere I don't have any specifics that can directly help, but i've read other threads in which something in the PBIX file corrupted and creating a copy (save as) to a new PBIX file resolved some internal error in the model. You could give that a shot, and see if the same error occures when uploading the new file. If you are having success connecting to the same datasource, I would assume it has something to do with the PBIX file itself.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post

3 REPLIES 3

@PauSempere I don't have any specifics that can directly help, but i've read other threads in which something in the PBIX file corrupted and creating a copy (save as) to a new PBIX file resolved some internal error in the model. You could give that a shot, and see if the same error occures when uploading the new file. If you are having success connecting to the same datasource, I would assume it has something to do with the PBIX file itself.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post

Hi @Seth_C_Bauer

I first tried copying the file and renaming it and it didn't work, but using "Save as" it solved the inner problem with the file and I was able to publish it with no problem. 

 

Thank you!

 

Regards.

Johanno
Responsive Resident
Responsive Resident

Thank you! I removed the dataset without removing the reports first and then I got this error.

 

An easy Save as solved the problem.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors