cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
PauSempere Frequent Visitor
Frequent Visitor

Error 400 Bad Request when publishing a PBIX file

Hi folks, 

 

using the last versions of Power BI and Enterprise Gateway I am trying to publish a PBIX file connecting to a on-premises SSAS server, but I am getting an Error 400 (Bad Request) when doing so. In the detailed error description I found this error

 

HttpStatusCode
BadRequest

ErrorDetails
{"error":{"code":"ModelHasNoPowerBIDMMoniker","pbi.error":{"code":"ModelHasNoPowerBIDMMoniker","parameters":{},"details":[]}}}

ErrorCode
ModelHasNoPowerBIDMMoniker

 

The gateway works correctly though, and I can see live data from the portal when I upload a new PBIX file with the same SSAS connection and any graph is added. 

 

I have not found any extra info about this error, any ideas about what can it be? 

 

Thank you in advance. 

 

Pau Sempere

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Error 400 Bad Request when publishing a PBIX file

@PauSempere I don't have any specifics that can directly help, but i've read other threads in which something in the PBIX file corrupted and creating a copy (save as) to a new PBIX file resolved some internal error in the model. You could give that a shot, and see if the same error occures when uploading the new file. If you are having success connecting to the same datasource, I would assume it has something to do with the PBIX file itself.


Near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post

2 REPLIES 2
Super User
Super User

Re: Error 400 Bad Request when publishing a PBIX file

@PauSempere I don't have any specifics that can directly help, but i've read other threads in which something in the PBIX file corrupted and creating a copy (save as) to a new PBIX file resolved some internal error in the model. You could give that a shot, and see if the same error occures when uploading the new file. If you are having success connecting to the same datasource, I would assume it has something to do with the PBIX file itself.


Near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post

PauSempere Frequent Visitor
Frequent Visitor

Re: Error 400 Bad Request when publishing a PBIX file

Hi @Seth_C_Bauer

I first tried copying the file and renaming it and it didn't work, but using "Save as" it solved the inner problem with the file and I was able to publish it with no problem. 

 

Thank you!

 

Regards.

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Kudoed Authors (Last 30 Days)
Users online (5,151)