cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
georgekhalil
Regular Visitor

Connecting to a SharePoint List Office 365

I am receiving the following error when trying to Get Data from an Office 365 SharePoint List. This is a subsite under the root site collection, however connecting to the root site collection works with no errors and I can see the various lists.

 

DataSource.Error: OData: The feed's metadata document appears to be invalid. Details: DataSourceKind=SharePoint DataSourcePath=https://gkm2solutions.sharepoint.com/Finance/_vti_bin/ListData.svc/$metadata

3 REPLIES 3
Super User IV
Super User IV

Re: Connecting to a SharePoint List Office 365

It's a bug, see this thread on Technet

https://social.technet.microsoft.com/Forums/en-US/63c57fd7-109a-4a2c-82a7-409494f19303/trouble-getti...

 


---------------------------------------

Not the Power BI thought police...

I have NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!
Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

teylyn
MVP

Re: Connecting to a SharePoint List Office 365

Hello,

 

Check that your list names don't have special characters or start with a number.

 

I had the same issue with an on premise SharePoint site. For me the problem went away when I changed a list name that started with numbers. Apparently the metadata file for the List Data service breaks when a list name starts with a number. 

 

http://<SitePath>/_vti_bin/listdata.svc/$metadata

 

If this returns an error instead of a long page with XML, check your lists for problematic names. 

 

I wrote it up in a blog post here: http://bit.ly/1OPeKwj

 

 

 

erickerson
New Member

Re: Connecting to a SharePoint List Office 365

I'm having the same issue.  I have no problem connecting to the root of my O365 SP site or other sites with trying to use the OData connection.  Here's my connection string: https://xxxxxx.sharepoint.com/hr/_layouts/15/_vti_bin/listdata.svc

 

I can connect to: https://xxxxxx.sharepoint.com/_vti_bin/listdata.svc just fine and I can even connect to https://xxxxxx.sharepoint.com/audit/_layouts/15/_vti_bin/listdata.svc just fine.  I don't know why I cannot connect to the "hr" subsite.  I'm getting "OData&colon; The fee's metadata document appears to be invalid" message.

 

Any help would be appreciated.

 

Thank you.

Helpful resources

Announcements
New Ranks Launched March 24th!

New Ranks Launched March 24th!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power BI Community!

‘Better Together’ Contest Finalists Announced!

‘Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Arun 'Triple A' Event Video, Q&A, and Slides

Arun 'Triple A' Event Video, Q&A, and Slides

Missed the Arun 'Triple A' event or want to revisit it? We've got you covered! Check out the video, Q&A, and slides now.

Top Solution Authors
Top Kudoed Authors