cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sdrevik Frequent Visitor
Frequent Visitor

Changing Gateway Settings to New DB- Old Report Can't Update?

So, I am still working on a method to deploy Reports created against database X to customer database Y.  In this case, we are using the same gateway.

Report is designed and working.   I go into the gateway settings, and create a new data source for database Y, enter credentials, connection test is OK.   Then I go into Power BI Desktop, open the Report, and use Edit Queries to Change Data Source.  I add the new database on the gateway, enter the credentials, everything tests OK.   Hit refresh.   Nothing updates.

Here's the strange part- the old parts of the report don't work, can't see any data.  But I can add a control to any of the pages, or add a new page and THOSE will see data from the new database.

Is there another step to 'update' all the controls against the new database??

1 ACCEPTED SOLUTION

Accepted Solutions
sdrevik Frequent Visitor
Frequent Visitor

Re: Changing Gateway Settings to New DB- Old Report Can't Update?

I figured out the issue.     The procedure is, roughly:

  1. Load up new database on customer SQL server, with remote access port open and password access.
  2. Go to https://app.powerbi.co, Gear icon, Manage Gateways
  3. Open Gateway Cluster->Add Data Source.  Fill out data
  4. Open Power BI Desktop, open PBIX, Edit Queries to change data source
  5. Ignore all the warnings and popups
  6. Edit credentials, make sure to select "Database" on the left
  7. Republish

Thanks!

 

3 REPLIES 3
Highlighted
Community Support Team
Community Support Team

Re: Changing Gateway Settings to New DB- Old Report Can't Update?

Hi @sdrevik 

Do you mean refresh from Desktop or Service?

If you view the report via Service, you may need to publish report from Desktop to Service again after changing data source.

Are the table structure and fields name the same for old data source and the new one?

If they are not same, you may see visuals including old data showing error

8.png

Could you show a screehsot of " the strange part- the old parts of the report don't work, can't see any data"?

 

Best Regards

Maggie

sdrevik Frequent Visitor
Frequent Visitor

Table structures the same

All table structures the same- in fact the database was backed up from development machine A and restored onto machine B.   republished- no data update.   Went back into designer, added a new page- sees data, no problem.  Publish- that page works, none of the rest do.

 

Interestingly, back on the original machine designer, it can't see data from the original database anymore either.  It's as if when I changed the data source from Machine A in development to Machine B, it just broke the entire report.   

 

It leads me to think ALL work in Desktop has to be done against the final SQL machine the data server will use, which is an insanely stupid limitation.    But I can't see any other way around it.

 

sdrevik Frequent Visitor
Frequent Visitor

Re: Changing Gateway Settings to New DB- Old Report Can't Update?

I figured out the issue.     The procedure is, roughly:

  1. Load up new database on customer SQL server, with remote access port open and password access.
  2. Go to https://app.powerbi.co, Gear icon, Manage Gateways
  3. Open Gateway Cluster->Add Data Source.  Fill out data
  4. Open Power BI Desktop, open PBIX, Edit Queries to change data source
  5. Ignore all the warnings and popups
  6. Edit credentials, make sure to select "Database" on the left
  7. Republish

Thanks!