cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kstiegler
Frequent Visitor

New field created in D365 not showing in Power BI Desktop via Power Query (Dataverse connector)

This has happened on multiple fields on different entities now, where I create a new field and the Power BI Dataverse connector doesn't pull it in during Power Query.

 

I create a new field on an entity (D365 Settings - Customizations - Customize the System - navigate to the User entity - open Fields view - go through new field creation dialog - save changes - publish changes) but when I open Power Query Power BI Desktop, the new field doesn't show up when I use the Dataverse connector. If I use the older OData feed connector, I can find the field, but I would prefer using the Dataverse connector since it is SO much faster and easier to use. 

 

Below is a screenshot of the created field on the User entity - is there some additional change or toggle or refresh required for the Dataverse connector to see this new field?

kstiegler_0-1623094075041.png

 

0 REPLIES 0

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.

Get Ready for Power BI Dev Camp

Power BI Dev Camp - September 30th, 2021

Mark your calendars and join us for our next Power BI Dev Camp!

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors