Reply
Frequent Visitor
Posts: 7
Registered: ‎10-08-2015

iPad line graph showing extra x-axis entries

Hi,

 

I have tried creating a line graph in a dashboard. The data I supplied is some data separated into 7 days, which is used as the x-axis. In the web version, iPhone and Android version the line graph, when clicking the tile to focus on it, is showing properly, i.e. When there is enough space it showed all 7 dates in the x-axis, and when there is not enough space it showed fewer dates. However in iPad, when I click the line graph tile, in the pop up line graph, which by default can accomodate more than 7 dates, always show extra entries (11 in my case), resulting in duplicated dates. E.g. I have data from Oct 1 - 7, on the x-axis it will show "Oct 1 Oct 2 Oct 3 Oct 3 Oct 4 Oct 4 Oct 6 Oct 6 Oct 6 Oct 7 Oct 7".

 

Is this a bug or is there someway to config the iPad to display how many entries on the x-axis in the pop up when clicking the tile?

 

Many thanks.

Frequent Visitor
Posts: 7
Registered: ‎10-08-2015

Re: iPad line graph showing extra x-axis entries

Just an update, I tested with some updated dates (e.g. Oct 3 - 9) and all the dates across all devices showed in a wrong fashion. Seems the x-axis entries deviated to the left (i.e. Below Oct 3 data shows Oct 4, below Oct 8 data shows Oct 9... etc) on web, android and iOS versions. I switched the line graph x-axis type to categorical and it showed up fine. The culprit seems to be the "Continuous" mode in the x-axis in line graph unable to correctly display the x-axis entries. Would appreciate if anyone can verify if this is so. Thanks.
Frequent Visitor
Posts: 7
Registered: ‎10-08-2015

Re: iPad line graph showing extra x-axis entries

To clarify, the extra x-axis entries on iPad issue still exists no matter categorical or continuous x-axis type. Extra entries still show up on iPad dashboard line graph tiles.

Switching x-axis type to categorical only help resolves on Android and iOS phone.

Moderator
Posts: 143
Registered: ‎06-24-2015

Re: iPad line graph showing extra x-axis entries

Hi @pinmsoft

We belive the latest updtaqe for the app had some fixes that should help resolve this issue.

Can you please update the version from the store and let us know if this is still occuring?