cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EmiliaB_123
Helper I
Helper I

Export to Excel changes column names

Hello everyone,

when I export my table from Power BI App to Excel part of the column headers get changed from "quantity" into "sum of quantity". I changed the headers in Power BI in order to have a better visualisation of this table and now the head is changing through the export. Can someone help me how to solve this?

Thank you!

1 ACCEPTED SOLUTION
Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

Oh! Sorry for my misunderstanding!

Please allow me to describe your issus again:

When you export the visual data from apps to excel , the prefix of "Sum of " appears in the column name , and you have set the default summarization to "Sum", right?

 

Now I could reproduce it! Please take a look at the differences:

3.31.1.export data1.PNG3.31.1.export data2.PNG3.31.1.export data3.PNG

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

10 REPLIES 10
Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

To my knowledge, each field with Number type will have Sum/Don´t summarize... options in Values tab.

options.gif

 

Did you try to use the second or third methods I provided before?

 

Please use my pbix file to have a try on your side.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Eyelyn9 ,

I get your correction advices, but I actually need the setting "sum" for this field. I just don´t understand why it only shows the wrong column header for two columns. The others are set the exact same way and it doesn´t show the "sum of..." in the title. 

EmiliaB_123_0-1618215086574.png

EmiliaB_123_1-1618215099595.png

 

Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

Oh! Sorry for my misunderstanding!

Please allow me to describe your issus again:

When you export the visual data from apps to excel , the prefix of "Sum of " appears in the column name , and you have set the default summarization to "Sum", right?

 

Now I could reproduce it! Please take a look at the differences:

3.31.1.export data1.PNG3.31.1.export data2.PNG3.31.1.export data3.PNG

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi @Eyelyn9 ,

thanks for those screenshots, but I don´t have the "Don´t summarize" option in my report for the field that shows the "Sum of..."´.

Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

Sorry for my late reply...Actually I'm confused about: this field is already set as "sum"

Did you mean that , the prefix of "sum of " still existed in the column in the exported excel file?

Did you try to re-export to see the changes?

Please share me with your pbix file from your Onedrive for Business after removing sensitive data. So that I could have a try again.

 

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

Hi @Eyelyn9 ,

you gave me the advise to change the value to "sum" and what I wanted to say is that it is already set as you gave me the advise to change it to. 

I can´t share the file actually because the field related is already senstitive data. 

Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

Please go to the Data view, select the column tools in question, then change the 'Default Summarisation' to 'Sum'. Now go back to the report design and re-create the table from scratch. The 'Sum of' will no longer appear.

3.10.2.export.PNG

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Eyelyn9,

thanks for your feedback but this field is already set as "sum".

EmiliaB_123
Helper I
Helper I

Hello @Eyelyn9

yes I did but I changed the name of the column afterwards and I did this with all the columns, but only two of multiple columns still show this behaviour.

 

Eyelyn9
Community Support
Community Support

Hi @EmiliaB_123 ,

 

Did you do some aggregation on the Quantity field like this:

3.8.2.export.PNG

Best Regards,
Eyelyn Qin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors