cancel
Showing results for 
Search instead for 
Did you mean: 

report embed using iframe broken suddenly for one report

Hi,

 

We have embeded serveral reports using iframe (below code) but yesterday one of the report suddenly broken. We tried the same report with same token using power bi js and its worked fine. We are now using power bi js only but need to understand the root cause for the issue since live site was broken because of this.

 

var $reportIFrame = $('#rpt');

$reportIFrame.attr("src", txtEmbedUrl);
;

$reportIFrame.on("load", () => {
    var messageStructure = {
        action: "loadReport",
        accessToken: txtAccessToken,
    }
    var message = JSON.stringify(messageStructure);
    var reportIFrameDom = $reportIFrame[0];
     reportIFrameDom.contentWindow.postMessage(message, '*');
});

 

NOTE: This report was in working since last 6 months and it was broken suddenly.

 

While debugging through the failure we got below logs:

 

{"ai.session.id":"nAiQ6","ai.device.id":"browser","ai.device.type":"Browser","ai.internal.sdkVersion":"javascript:1.0.14","ai.user.id":"rGs4l","ai.operation.id":"CXUcn","ai.operation.name":"/reportEmbed"},"data":{"baseType":"EventData","baseData":{"ver":2,"name":"PBI.ReportEmbed.LoadEmbeddedReport","properties":{"sessionId":"c761435b-0f50-4c9f-86d3-aaa317e79c60","client":"PowerBI.com","build":"13.0.5027.118","cluster":"https://df-msit-scus-redirect.analysis.windows.net","userId":"00000000-0000-0000-0000-000000000000",...":"********-****-****-****-************","embedType":"SaaSEmbed","embedUrl":"","referrer":"","parentId":"e50a34c3-af3f-0230-2245-91e717f6ccfe","isError":"true","errorSource":"PowerBI","errorCode":"SAAS embed: Fail to initialize - Could not resolve cluster HttpStatusCode: 403","activityName":"PBI.Dashboard.RootSession","activityId":"e50a34c3-af3f-0230-2245-91e717f6ccfe"}}}}]"

 

 

Help to identify the root cause is highly appriciated.

Status: New
Comments
Community Support

Hi @chetanchopade,

 

Based on my test, use postMessage to embed is working fine on my side.  From the error message " Could not resolve cluster HttpStatusCode: 403", I guess the issue is related to Power BI embedded service in your cluster.

 

I would suggest you test again. If issue persists, please share RequestID with us during the time the error occurs. 

 

Best Regards,
Qiuyun Yu 

Frequent Visitor

Hi All,

 

Is this problem has been solved? I also have the same problem.

Recently I switched my PowerBI dedicated resource to another account,

the credit amount has decreased, but the report doesn't show.

 

message: "LoadReportFailed", 
detailedMessage: "SAAS embed: Fail to initialize - Could not resolve cluster", errorCode: "-1", level: 6, 
requestId : "c8be348e-e3b4-86f3-96d6-85aa0fb7f566"

 

Can someone help me? 

 

Thank You

Anonymous
Not applicable

 hi @eddywijaya,

 

Did you get the solution,if yes pls let me know.

 

Thank you.