cancel
Showing results for 
Search instead for 
Did you mean: 

"Creating connection in model" - Doesn't show rows being downloaded anymore.

Hi!


Since September 2021 Update, when refreshing data using Power BI Desktop connected to Azure SQL Server, it goes like:
Evaluating - OK
Waiting for other queries - OK

Creating connection in model ... (Stays here until all data is loaded)

I have more than 100 Power BI files in my organization, all of the connected to Azure, so it is not a specific file that has this behaviour. Every file I try is the same.

At first I thought it was stuck there, but If the file is big, lets say 4 Million rows, it takes sometime and eventually loads the data. But it doesn't show the amount of rows being downloaded anymore. And believe me, this is my daily routine, importing, updating and building reports.

This is misleading because you can't differentiate if the process is stuck or going all right anymore. You just have to have faith that is working, but when it takes too long it is complicated to be waiting without knowing that it is going to load correctly.

I was hoping that this would be fixed in October 2021 release but had no luck.

Anyone else experiencing this?

Thanks in advance!

@amitchandak 

Status: Delivered
Comments
Tony_XXX
Regular Visitor

Hi, i think there is similar issue and vote

Stuck at Creating Connection Model - Microsoft Power BI Community 

v-robertq-msft
Community Support

Hi,

A similar issue has been reported internally, so stay tuned.ICM: 263271425

 

And this is the latest updated information from the pg:

 

We have a fix for this internally, which will be released in the November version of Power BI Desktop.

 

I will update here once I get any information.

 

Best Regards,

Community Support Team _Robert Qin

v-robertq-msft
Community Support
Status changed to: Accepted
 
ID_PB
New Member

I have similar issue inmy organization. Looking forward to November update

Thank you

wellf100
Frequent Visitor

When will this be fixed for Report Server version?  Absolute nightmare at the moment as I can't refresh any dashboards and reverting back to May 21 RS version of PBI Desktop is not helping as it won't load up (error at splash screen)

zapppsr
Kudo Collector

I'm working rolled back to August.

 

wellf100
Frequent Visitor

rolling back to Aug works, in so much as i can refresh,  but we use the on premise report server version and there are specific releases (like May 21 and Sept 21) which are optimzed for use with report server.  Using one that isn't, such as Aug 21, gives me the risk of building or modifiying a dashboard and it not being compatible with the Report Server.

 

How this Sept 21 issue was not picked up before release I really cannot understand.

zapppsr
Kudo Collector

October 22, 2021, new release: 2.98.882.0

I was hoping it was the fix, but no luck. 

Tested and same behaviour.

Let's wait for November release then...

zapppsr
Kudo Collector

Apparently fixed in today's version: 2.98.1004.0

v-robertq-msft
Community Support
Status changed to: Delivered