cancel
Showing results for 
Search instead for 
Did you mean: 

on-premises data gateway's service account failed to impersonate the user

Gateways are running, on, and all test connection work but reports cannot be updated since on-premises data gateway's service account failed to impersonate the user

Status: New
Comments
DanL
Regular Visitor

@Anonymous @_chriZa_ @Anonymous  I wanted to pass along some instructions I received from an MS engineer that restored our SSO functionality. Disable SSO on the gateway, follow the directions below, restart the gateway, then reenable SSO:

 

sso reenable.jpg

yh_low72
Regular Visitor

Strongly beleived is caused by the Power BI services update on 14-Feb-2020. 

Please go to the Power BI gateway setting and uncheck "Use via Kerbeors for DirectQuery queries. after uncheck this i managed to rerun wihtout the errorgatewayissue.jpg

MaciejSowa
Advocate I

Same issue but in our case user which is owner of the dataset is a member of the AD group which has permissions to read the database on SQL Server.

henkjul
New Member

Same issue here. I came back from vacation and our customer was complaining that SSO is not working anymore.

 

It is not an option to disable SSO since we need the RLS. Microsoft has to fix this as soon as possible

amoto
Frequent Visitor

Dear colleagues,

 

In our case we solved it. We identified the issue wich was not related the gatway but something in our server due to MS updates.-

 

1.- We noticed that the .NEt framework was updated in our server to 4.8 version, however, one Microsoft engineer advised us that still the compatible version is the 4.7.2, so, we downgraded the version.

2.- together with this we re-install the Database Access Engine (we have many data sources pointing Access tables)

3.- Update again to the latest version of Gateway and PBI Desktop and Mysql connector to make it sure that all the registry keys were updated

 

After this,all our datasources come back to smooth and error-free refresh., 

 

Seems that the wrong .Net framework together with the Dabase Engines led to interminten corrupted mushups, after the above updates this problem dissapears.

 

Hope this can help to those colleagues with the same issue.,

 

saludos 

 

 

 

After that, all the refreshes

Anonymous
Not applicable

My issue has been resolved. I tried adding the user account for which the dataset(Configured for Analysis server) was failing to refresh because of the error -"failed to impersonate the user" .
I went to SSMS Analysis Server --> properties> security.

I added the user account, restarted on-premises gateway and rereshed the dataset on PowerBI, the error went and  it started working.

(just an fyi, User account is the one I used for configuring the Analysis server datasource)

 

I follwed below link to reslove my Analysis server issue.:
https://docs.microsoft.com/en-us/analysis-services/instances/grant-server-admin-rights-to-an-analysi...

Anonymous
Not applicable

Hi All,

Today I faced this issue "The on-premises data gateway's service account failed to impersonate the user.".

 

I am not sure, there was any change on the machine where I Have installed "On-premises data gateway". 

 

in my case Gateway Service account "UserSA" is a account which has admin permision on the machine where the gateway is installed.  Also already "Use SSO via Kerberos for DirectQuery queries" option under "Advanced Settings" is unchecked. 
I can see one difference here: in Data Source Settings, Username, I have given mine and when I change it to Service Account "UserSA". It works fine. 

Also I checked with infra guy, and he aadded my account as Adminstrator to the machine where Data gateway is intalled and then I went back to Data Source and changed credentails to mine and it works now. 

Data-101
New Member

Hi guys,

 

First post and sharing my experience.

I was having the same issues as well. The client has mentioned that refreshed had stopped and there were no known major changes. I tried logging in again and reinstalling, rebooting the box etc but to no avail.

 

What worked for me was to setup a new gateway and voila, data starts refreshing again.

I was getting the error message "The on-premises data gateway's service account failed to impersonate the user." when trying to connect.

 

I changed the service account used from PBIEgwService to a domain admin user, re-created a new gateway connection, reports to reconnect to the new gateway and republish the reports. Happy client.

 

HTH.

cheers,

Ben

kakirr
Microsoft

We are experiencing the same issue. Any solution here yet?

doubleJSA
Helper I

This could also be a domain issue with the username.

When setting up the connection from the Power BI service (cloud) to the datasource, via the gateway, ensure that the full username is entered for the data source eg: my_domain\username

 

Without the 'my_domain' portion included in the username, we are unable to connect to the local SQL db. Error message: 
Gateways are running, on, and all test connection work but reports cannot be updated since on-premises data gateway's service account failed to impersonate the user