New Idea

I enable modern visual header and hidden Expand option and published to service. It worked as expected in web, but it's not working in Power BI Mobile application.
I feel there is a mismatch between the drill down options between web and mobile. Correct me if I am wrong?

Status: Accepted

Hello,

 

I am getting an error "Access to the resource is forbidden" when trying to access Microsoft Graph in Power BI Desktop report.

Microsoft Graph URL is https://graph.microsoft.com/v1.0/devices

I am logging in using Organization Account.

I have Global Admin role in the tenant.

 

The report was working normally for months, but stopped since yesterday.

I even tried creating new one - same result.

Accessing the same URL from Graph Explorer works fine.

 

What could actually impact this kind of error?

While some users can open the reports without problems, other users get a message ... Loading data... and keeps spinning forever.

These users could open the reports before with no issues. 

Some reports are direct query other are imported data, so it is not an underlying db issue.

What is going on??

There was a similar issue last year. It seems that has re-occured.

 

https://community.powerbi.com/t5/Issues/Bug-Trying-to-Publish-in-the-service-without-saving-the-file...

 

When I attempt to publish a report and have not signed  into the Desktop yet, a command prompt box appears then disappears and Power BI crashes. Also, it seems that   after the January 2018 update, Power BI requires to re-signin for each report created prior to installing the  update.  Normally after I have  already signed in, Power BI will not request for  another  signin the next time  I open the same report. 

Status: Accepted

IE11 crashes when consuming report

Status: Accepted
by bosse_ Visitor on ‎08-30-2018 11:12 PM
Hi!
 
I have a quite simple report and a small size dataset behind (approx 2000 rows in largest tabel, total 5 tables).
The report is based of 3 slicers (shown as dropdowns) and 4 100% stacked bar charts.
 
The problem accours when consuming this report in IE 11, no matter if it is consumed by app.powerbi.com or in "publish to web" mode. The report will crash when selecting from all of the 3 slicers, idependent which order you pick. Even if the the last slicers only show 1 option, yhen you choose that option IE11 is shutting down and the message "A problem with this webpage coused Internet Explorer to close and reopen the tab.". It occours every time, i even tried to recreate the report in lastest version of Power BI Desktop but no nothing change. If I remove the slicers, or edit 100% stacked bar charts to pie diagrams it all works! If att used another stacked bar diagram (not the 100% one) the problem is still there.
 
Everything works fine in Edge, Chome etc. I have updated IE11 to the latest version; 11.228.17134.0
 
Any ideas?
 
Best regards
Status: Accepted

August release: Refresh never completes

Status: New
by xerxel Frequent Visitor on ‎08-17-2018 03:33 AM

Model works and refreshes in July release. Tried in August release on two machines and refresh never completes. Model contains links to Sharepoint online and SFDC. Sharepoint data loads slowly and SFDC never completes. Model includes custom functions.

 

How can we debug the difference between August vs July of the exact same model?

 

 

Reports are not working in the service

Status: Needs Info
by Steffen Frequent Visitor on ‎11-17-2017 05:15 AM

For the last 30 minutes it has not been possible to show reports in the service. They are just loading and never finishes. I have tried with reports from different sources, so the problem is in the Power BI Service. 

 

Can someone fix this ASAP? I'm based in northern europe.

Status: Needs Info

Color Saturation option missing on charts

Status: Delivered
by lehuok Frequent Visitor on ‎11-15-2018 04:09 PM

Hello, since upgrading to November 2018 version, the "color saturation" bucket is missing from most charts, bar / column, stacked / clustered. I have confirmed it works ok in previous PBI Desktop version. This is serious issue as we now cannot modify existing reports using this functionality.PBI november 2018.pngNovember - missingPBI october 2018.PNGOctober - color saturation is there

Status: Delivered

Usage Metrics Not Tracking All Views

Status: Needs Info
by caseybowyer Visitor on ‎09-21-2018 09:41 AM

We track dashboard usage metrics for accountability in our organization.  We've noticed that some viewers' activity is not being tracked in the usage metrics report.  Their views do not show up in usage metrics for the dashboard view or report view of our presentation.  They have definitely viewed the dashboard -- we've watched them share their screen while looking at it.

Status: Needs Info

I try to get my table from my dataset in Bigquery into Power BI Desktop. But unfortnately I m getting to follwing error:

 

DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job first-projec:job_dm6z7i391YiYbOwjL7t-ydZ4V26dd6dfnv8
Details:
DataSourceKind=GoogleBigQuery
DataSourcePath=GoogleBigQuery
OdbcErrors=Table

 

I tried the following to lose this error:

- Changing this line in the M source code:

Quelle = GoogleBigQuery.Database(null)

to:

Quelle = GoogleBigQuery.Database([BillingProject="Billing-Project-Id"]) 

- I used the Simba ODBC driver as described here : Simba-BigQuery-ODBC-Driver-Quickstart2.pdf

 

Is this still a bug in Power BI?

 

P.S: my dataset and google cloud storage are in the same region, europ-west2

 

 

Selecting colors in Data Color tab on visuals and they are not accurate

Status: Accepted
by Shelley Member ‎10-05-2018 01:21 PM - edited ‎10-05-2018 01:34 PM

Ever since the September release, when I select colors in a data colors tab, the color I select is not what PBI applies. I am using a JSON color theme - it always worked just fine - but with this release it does not. I tried reloading the JSON file and still the same. I try to select green and it applies pink, for example. This is making PBI useless for conditional formatting. In addition, I cannot select any colors accurately at all, so my file looks like a piece of junk.

Status: Accepted

Hi,

 

I am working as a BI Consultant at a Microsoft Partner and I first discovered this bug at a customer and I have now been able to recreate this on my test/development server.

 

First some technical stuff:

Power BI Desktop 2.62.5222.601 64Bit (September 2018)

On-Premise Data Gateway 14.16.6792.1 (August 2018) (I am not able to upgrade this, due to the fact that the new installer requires Windows feature that are currently in preview, but our IT department don't want preview features on servers - but this is another matter)

Analysis Servers (Tabular) 13.0.4001.0 (Standard Edition)

 

Bug Description:

Whenever I try to create a Report Measure in Power BI Desktop using a live connection to a Dataset on Powerbi.com (also tried with direct connection to my SSAS model), it semi crashes Analysis Services.

 

As a test, I tried with a very simple measure. In my SSAS model I have 2 measures [Sales Amount] and [Sales Quantity] and then I want to calculate [Sales Unit Price] as DIVIDE( [Sales Amount]; [Sales Quantity] ). However, if I create this report measure and start using it in a visual the original [Sales Amount] and [Sales Quantity] measures from the model stop working (of course including all other measures in the model that uses either of the measures in their calculation), but other measures like [Sales Cost] is still working. If I create a measure in the SSAS model with the exact same formula there is no problem.

 

To get the [Sales Amount] and [Sales Quantity] measures working again I either have to full process the SSAS data model or restart Analysis Services service. Then everything is working again until I open the Power BI file with the calculation and this file makes a query against the data model.

 

I have created a .zip file with .pbix files, event viewer errors and a backup of Tabular model

Download Files

 

Please let me know if there is more information you need to fix this.

Line Chart is blank after scroll in Power BI Service

Status: Accepted
by prateekraina New Contributor ‎07-03-2018 02:30 AM - edited ‎07-04-2018 10:52 PM

Hi Team,

 

There seems to be a bug which is causing Line charts to go blank when we scroll on Power BI Service.

It works fine on Power BI Desktop.

 

I have verified that this issue is across all my reports on Service. Also, @odoardil has posted this issue on Community Portal where several other users have acknowledged this.
http://community.powerbi.com/t5/Service/Line-chart-is-blank-when-using-scroll/m-p/449100#M47469 

 

On behalf of everyone, I am posting this issue here. Kindly resolve this bug ASAP as our production reports are useless due to this bug.

 

Prateek Raina

Status: Accepted

Fix the "Data Loading" / "Almost Done" issue

Status: New
by SMHolck Frequent Visitor on ‎10-02-2018 02:56 PM

Multiple people in my organization are unable to view published apps in our Power BI tenant.  They can sometimes click Apps and then wait for it to load forever.  You see a brief message "Data Loading" followed by "Almost Done."  And it will spin for hours.  My entire company has a Pro license.  The data loads fine in my Power BI desktop.  Issue happens on both IE 11 and Chrome 69.   Good thing I'm not currently doing my presentation on why you should use Azure!AlmostDone.png

 

I've seen this happen often and on.  You never know when it is going to happen.  My Azure admin says when he logs in to Azure portal it tells him no known outages.

 

 

As per the title all basic date slicers are stuck in the US date format and cannot be changed. My regional setting are set to UK and changing this around does not fix the issue.

Status: Accepted

Incremental refresh breaking timezone

Status: New
by archie824 Frequent Visitor on ‎12-06-2018 12:51 PM

Data comes in UTC. I made a column using 

DateTimeZone.SwitchZone(DateTime.AddZone([CreatedDateTime],0,0),-7)

This works fine, until incremental refresh kicks in, and turns the new column into the same time for both CreatedDateTime and the new column. Not sure if anyone else is experiencing this.

Hi, I have this error appearing when I try to load the data. I started to get it after I updated PBI Desktop to the latest version. Before it was working fine. Please, help me:


Frown (Error)

Error Message:
Value cannot be null.
Parameter name: modelingRelationship

 

Thanks

 

1) When republishing an existing report to our v2 workspace we get a 500 error and are unable to publish. deleting the report and associated dataset from the workspace unblocked us and we were able to publish.

 

2) Now that we've published an app from the workspace, we are unable to publish new reports to the workspace. Unpublishing the app and then republishing the app is not an option as the app is already distributed to 100 people.

 

3) when going to the schedule refresh page of a dataset someone else published, in the preview workspace, the "Take Over" button give an error as well.

Status: Accepted

Hello there, we have some published reports using the Facet Key custom visual, however today those visuals are not working in any level (not the PBIX in desktop, neither the ones in our workspaces and not even the ones that we previously published to web).

 

Here are the things I have tried so far:

- Updating the visual from the marketplace

- Deleting the visuals and create them again

- Activating the "Modern visual header with updating styling options" in the desktop reports

- Saving that previous file with another name and even as a template

- Publishing the report to a workspace, and export it as a PBIX

 

So far the only way I have found this visual to work again is to create a file from scratch and draw everything again. However since we have lots of reports created and lots of work done in the query editor, data editor and in the report itself, we would like to avoid this solution if another one may be suggested.

I also matched the "Current file options" in the new file with the old ones and still didn't work.

 

Help would be appreciated.

Regards

Status: Accepted

Not able to open PBI file (even new blank one)

Status: New
by JorisVoorn Frequent Visitor on ‎03-16-2018 04:51 AM

After instalation of PBI Desktop update (March) I am not ableto open any PBI file (even new blank one). I tried to repair PBI desktop via Control PAnel, reinstall back to rpevious verison, change x64 bit to x32 bit version, but nothing worked. 

 

Error messages varies based on PBI file that i am trying to open, below is one of the error logs that PBI shown me after PBI failed. Sometimes is error message only announcement that PBIDesktop is not able to load data modle and nothing else (what is kinda strange when this error message appear during opening of blank PBI file...

 

Feedback Type:
Frown (Error)

Timestamp:
2018-03-16T11:34:23.0617108Z

Local Time:
2018-03-16T12:34:23.0617108+01:00

Session ID:
a986f59a-fb3f-477b-852e-f5c8a5ebf5a6

Release:
March 2018

Product Version:
2.56.5023.942 (PBIDesktop) (x64)

Error Message:
Couldn't load the model schema.

OS Version:
Microsoft Windows NT 10.0.16299.0 (x64 en-US)

CLR Version:
4.7 or later [Release Number = 461308]

Peak Virtual Memory:
35.5 GB

Private Memory:
1.08 GB

Peak Working Set:
1.06 GB

IE Version:
11.309.16299.0

User ID:
f140123a-0dfa-4434-8f7c-e25e9a0abb0a

Workbook Package Info:
1* - en-US, Query Groups: 5, fastCombine: Enabled, runBackgroundAnalysis: True.

Telemetry Enabled:
True

Model Default Mode:
Import

Snapshot Trace Logs:
C:\Users\v-pavsch\AppData\Local\Microsoft\Power BI Desktop\FrownSnapShot360440546.zip

Performance Trace Logs:
C:\Users\v-pavsch\AppData\Local\Microsoft\Power BI Desktop\PerformanceTraces.zip

Disabled Preview Features:
PBI_shapeMapVisualEnabled
PBI_EnableReportTheme
PBI_numericSlicerEnabled
PBI_SpanishLinguisticsEnabled
CustomConnectors
PBI_AdobeAnalytics
PBI_qnaExplore
PBI_variationUIChange
PBI_customVisualsGallery
PBI_canvasTooltips

Disabled DirectQuery Options:
PBI_DirectQuery_Unrestricted
TreatHanaAsRelationalSource

Cloud:
GlobalCloud

DPI Scale:
125%

Supported Services:
Power BI