0 Kudos

error "unable to get property 'value' of undefined or null reference" when linking text fields

Status: New
by ShawnDevin Visitor on ‎11-15-2018 09:52 AM

I am creating a new copy of a report with a text column that is a combination of two fields (in my case text account ID, a pipe delimiter, and the month year in yyyy-mm format) to allow joining the two tables on two fields simultaniously.

 

when dragging one accountMonthYear column onto the other I got the error message: unable to get property 'value' of undefined or null reference.  The first table showed rows of data, but the second, larger table was empty.

 

I found a workaround by dragging account number from one table to the other, the link dialog shows properly with both tables filled in.  I then changed the selected columns to the ones I wanted to join on and it worked properly.

bad join.jpgjoin on account and change the value.jpg

Comments
by Moderator v-qiuyu-msft
on ‎11-15-2018 11:17 PM

Hi @ShawnDevin,

 

From your description, it seems you are get data in DirectQuery mode, in Power BI desktop, you have created the same calculated column AccountMonthYear in these two tables 'MasterAccountList' and 'sysdba OPPORTUNITY', when you create a relationship based on AccountMonthYear column, error occurs, right? 

 

I have tested in the latest Power BI desktop version 2.64.5285.701 but not reproduce the issue. Please update your Power BI desktop to this new version then test it again. 

 

Best Regards,
Qiuyun Yu 

by rahulshevde Occasional Visitor
on ‎11-16-2018 09:11 AM

Hi @ShawnDevin

 

Can you please try with the november version of the power bi desktop and see if you still run into this issue? I think this issue was fixed in the November release. 

Thank You

Rahul Shevde 

by ShawnDevin Visitor
‎11-16-2018 10:08 AM - edited ‎11-16-2018 10:08 AM

I am using the windows store version of power bi desktop.  I opened windows store this morning and saw a new update as of yesterday to 2.64.5285.701 64-bit (november 2018).  It still displays the same behavior on the same data column.

by Community Support Team
on ‎11-17-2018 12:00 AM

@ShawnDevin

 

Are you able to switch your connection mode from "DirectQuery" to "Import". With Import mode, are you still able to repro the same issue? If yes, could you please help share the .PBIX file to me? We will help look into your issue.

 

Best Regards,

Herbert

by ShawnDevin Visitor
on ‎11-19-2018 11:02 AM

 I was able to switch to Import mode and found something unexpected.  The link is created when dragging the field from one table to the other, but if you open the link to view it, you see the same error.

If I delete a lot of columns from the source table (I was trying to shrink the pbix file) the error eventually goes away.  I noticed in particular if I deleted the notes column (and a couple of others) the error stopped occurring, or if I just delete more of the other columns but left notes, the error went away.  Maybe its a record size issue?

 

how do I send the file to you?

by Community Support Team
on ‎11-19-2018 05:23 PM

@ShawnDevin

 

You can send the .PBIX file to haibin.liu@microsoft.com

 

Best Regards,

Herbert

by ShawnDevin Visitor
on ‎11-20-2018 11:22 AM

Ok, I have emailed you a dropbox link to the file (its about 59 meg).  

by stefffel Visitor
on ‎12-07-2018 03:01 AM

Hi everybody. I'm getting the same error (since about one week). The issue is related to one table for which 6 out of 10 relations not working any more.

I'll now check with the support if we can update the PBI desktop with the latest version.

Regards

Steffen

Idea Statuses