cancel
Showing results for 
Search instead for 
Did you mean: 

connecting Bigquery to Power BI Desktop (Error : Job Not Found)

I try to get my table from my dataset in Bigquery into Power BI Desktop. But unfortnately I m getting to follwing error:

 

DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job first-projec:job_dm6z7i391YiYbOwjL7t-ydZ4V26dd6dfnv8
Details:
DataSourceKind=GoogleBigQuery
DataSourcePath=GoogleBigQuery
OdbcErrors=Table

 

I tried the following to lose this error:

- Changing this line in the M source code:

Quelle = GoogleBigQuery.Database(null)

to:

Quelle = GoogleBigQuery.Database([BillingProject="Billing-Project-Id"]) 

- I used the Simba ODBC driver as described here : Simba-BigQuery-ODBC-Driver-Quickstart2.pdf

 

Is this still a bug in Power BI?

 

P.S: my dataset and google cloud storage are in the same region, europ-west2

 

 

Status: New
Comments
Moderator

Hi @ayoubonik,

 

When you use another client application eg: Microsoft Excel or Tableau, does the same issue occur? 

 

In Power BI desktop, there is a built-in Google BigQuery connector for us to get data, you can use this connector instead: https://docs.microsoft.com/en-us/power-bi/desktop-connect-bigquery

 

Best Regards,
Qiuyun Yu 

Occasional Visitor

I have the same issue and i used the built-in Google BigQuery connector.

 

When i select public data it works fine, but not with private data from my BigQuery.

 

Big Query runs the job, but it seems that Power Bi can not get the result back. 

Moderator

Hi @KaiMe,

 

Is there any error displays when you get private data? 

 

Please open a blank query, and type Power Query instead of use UI to see if the same issue occurs(please replace bigquery-public-data with your project name and austin_311 with your table name: 

 

 

let
    Source = GoogleBigQuery.Database(null),
    #"bigquery-public-data" = Source{[Name="bigquery-public-data"]}[Data],
    austin_311_Schema = #"bigquery-public-data"{[Name="austin_311",Kind="Schema"]}[Data],
    #"311_service_requests_Table" = austin_311_Schema{[Name="311_service_requests",Kind="Table"]}[Data]
in
    #"311_service_requests_Table"

 

Best Regards,
Qiuyun Yu

Occasional Visitor

Hi @v-qiuyu-msft

 

thanks for your information.

I get this error while loading:

DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job first-project-212208:job_JaW_OfZLkaDm8nZT5CRn_NCYkBbf
Details:
    DataSourceKind=GoogleBigQuery
    DataSourcePath=GoogleBigQuery
    OdbcErrors=Table

 

and create this query:

let
    Source = GoogleBigQuery.Database(null),
    #"first-project-212208" = Source{[Name="first-project-212208"]}[Data],
    talpa_Schema = #"first-project-212208"{[Name="talpa",Kind="Schema"]}[Data],
    test_Table = talpa_Schema{[Name="test",Kind="Table"]}[Data]
in
    test_Table

In Big Query the job was succesful:

 

BigQuery job.png

 

I think power bi has some issues with getting the data from big query job or there is a bug in the REST-API

 

Best regards

 

Kai

 

 

 

Visitor

I have an same issue.

My dataset is in BigQuery asia-northeast reagion.

 

Yes, Bigquery job done in successful, but PowerBI responsed 100 error "not found : job"

Visitor

I try with my GCP billing table. It success to connect bigquery table but it is not correct tabel data.

each columns has json text.

 

Bigquery preview


bq_preview.PNG

 

 

 

 

 

 

 

 

 

 

PoweBI desktop(2.65.5313.701 64-bit )

pbidsktop.PNG

 

 

 

 

 

 

 

 

but my large size table still get "DataSource.Error: ODBC: ERROR [HY000] [Microsoft][BigQuery] (100) Error interacting with REST API: Not found: Job [tablename]:[jobId]

 

this jobId can't find my bigquery consle.

 

@v-qiuyu-msft

 

 

 

Visitor

I found a workdround.

This issue occurs in non-US region dataset of Bigquery.

 

I re-import to US region my private dataset, and Power BI desktop works well.

Advisor

We are seeing exactly the same issue with regions as reported by @gentksb .

 

It's also reported by others in a closed issue on this docs page:

https://docs.microsoft.com/en-in/power-bi/desktop-connect-bigquery

 

Presumably a bug in Power BI's implementation of BigQuery.  It's very frustrating.