cancel
Showing results for 
Search instead for 
Did you mean: 

Urgent Help Needed: Troubleshooting using Excel saved in Sharepoint as a dataset

Hi all,

 

A bit of context, I have published a PowerBI report and have shared it across to my team via Teams. For the report, I have been using an Excel file as the dataset. I have set it to autorefresh every day at midnight. So far, the auto refresh has been working perfectly for the past 2 months or so. However, today I got an email notification notifying me that the refresh failed. This was the error displayed:

 

Web.Contents failed to get contents from 'https://redactedhisonpurpose.sharepoint.com/sites/DealPipelineforDirectPE/_api/web/getfilebyserverrelativeurl('/sites/DealPipelineforDirectPE/Shared%20Documents/PE%20Direct%20Deal%20Pipeline.xlsx')/$value' (404): Not Found

 

I thought that it was weird, as it seems to me that the PowerBI service was not to able to find the file. I tried manually going to the url via a web browser, and was met with a 404: Not Found Error. I thought this was weird, as it has never ran into this kind of issue before. 

 

The next step in troubleshooting was me trying to replace the dataset manually. I went into the report via PowerBI desktop and attempted to change source for my dataset. I inserted a new sharepoint url (have made sure that the url can be found) and tried to change it, but I was met with this error

 

sharepoint issue.png

 

It says that it was not able to authenticate based on my credentials. I am positive that my Office365 email and password are absolutely correct. I am not sure why I am getting this error.

 

I appreciate any help in sorting this issue. Many thanks in advance!

Status: New
Comments
Community Support

Hi @rjsidek

 

I would suggest you go to SharePoint online, find the Excel file, then get a link from Excel in Excel desktop app. In Power BI desktop, create a new web data source with this URL. See: https://docs.microsoft.com/en-us/power-bi/desktop-use-onedrive-business-links

 

If you can get data successfully, then you can replace original web data source URL with this new one, ensure the report is refreshed successfully in Power BI desktop then republish the report. 

 

Best Regards,
Qiuyun Yu