cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to validate Web.Contents request for refresh and "Skip Test Connection" option is missing

I'm using a Web.Contents call in a source query and while it works on the desktop client, when attempting to set the dataset for scheduled refresh, the "data source can't be refreshed because the credentials are invalid".

 

I cannot follow the suggestion to use the "Skip Test Connection" made here (https://blog.crossjoin.co.uk/2019/04/25/skip-test-connection-power-bi-refresh-failures/) because that option does not appear.

 

I also cannot circumvent what appears to be the static analysis check on the Web.Contents call as suggested here (https://blog.crossjoin.co.uk/2016/08/23/web-contents-m-functions-and-dataset-refresh-errors-in-power...) because no part of the URL can be resolved successfully.

 

The exact line I am attempting to use looks like this:

Source = Json.Document(Web.Contents("https://api.appcenter.ms/v0.1/apps/", [Query=[start=DateTime.ToText(Date.AddMonths(DateTime.LocalNow(), -1), "yyyy-MM-dd"), errorType="UnhandledError"], Headers=[#"X-API-Token"="XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"], RelativePath="[AppOwner]/[AppName]/errors/errorCountsPerDay"]))

 

An example of the call without the dynamic date placement would look like this:

https://api.appcenter.ms/v0.1/apps/[AppOwner]/[AppName]/errors/errorCountsPerDay?errorType=Unhandled...

 

Without the ability to skip connection validation, I have to republish every day to get up-to-date data.  Is there another workaround for this that I am unaware of?  Is there a reason I do not see the "Skip Test Connection" option?

Status: Delivered
Comments
Regular Visitor

I've exactly the same problem. The interesting thing is that last week i saw this Skip connection test checkbox, but today when i've finalized my report, this checkbox was missing. I suspect, they've removed this feature...

Community Support

Hi all, 

 

Unfortunately I don't have such data source to test the issue on my side currently. For your issues, I would suggest you create a support ticket to let engineers look into the issue on your side. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu 

Community Support
Status changed to: Delivered
 
New Member

I did exactly this and received this error message:

SyntaxError.PNG

 

The underlying site states:

Welcome!  The page is migrated to new BI@Microsoft site.

We will be redirecting to that Page.

 

I have filed a ticket on the BI@Microsoft page.  Hopefully that was the appropriate place to have done so. 

Regular Visitor

Hi Guys,

 

could you please provide me a link to the Ticket you have created for this issue?

 

Thanks,

Gábor

Frequent Visitor

I have the same issue, I used the "Skip Test Connection" before. This works fine, but since it is not available anymore it say's "Credentials are invalid" (which is not the case).

Is there someone who knows a workaround or fix for this?

Regular Visitor

Hi All,

 

according to this article's update from Microsoft:

https://powerbi.microsoft.com/en-us/blog/skip-test-connection-for-on-premises-and-cloud-data-sources...

 

they removed that featrure due to issues...

 

Update: Due to few issues identified recently, we have temporarily disabled the “skip test connection” feature . We are working on making this available again for on-premises data sources by late-June. For cloud data sources we don’t have an ETA yet, but will circle back as soon as we do.