Showing results for 
Search instead for 
Did you mean: 

Unable to refresh

Unable to Sign into Organization Account 

I am trying to get refresh data,

data resides in the MS  Teams and its an excel file, so when i try to fresh data using Organizational Account credentials I cant login but I am getting the following error :




Status: New
Community Support


I have tested on my side, it works well.


Try to uninstall and reinstall the latest version power bi desktop.


if that doesn't work try to find Microsoft.Web.WebView2.Core.dll on system and then copy into the "bin" folder of the Power BI installation.





Regular Visitor

This just started for me this week as well. It happens when I try to refresh my org credentials in order to access an Excel workbook data source stored in SharePoint. This has worked for several years and just broke this week.


The missing assembly is the error message is Microsoft.Web.WebView2.Core.dll version 1.0.664.37. That DLL is in the Power BI bin folder but is version 1.0.674.0. It looks like the app was distributed with a newer WebView2 DLL than some other component requires.

Regular Visitor

I should add that this appeared in Power BI Desktop x64 version 2.92.1067.0 64-bit (April 2021)

Regular Visitor

A new release 2.93.641.0 came out today (5/12/2021) but does not address this issue. Same error. The version of Microsoft.Web.WebView2.Core on disk is still the same, and apparently whatever assembly needs it still wants an older version.


Here are the details:


Feedback Type: Frown (Error) Error Message: Could not load file or assembly 'Microsoft.Web.WebView2.Core, Version=1.0.664.37, Culture=neutral, PublicKeyToken=2a8ab48044d2601e' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)


Stack Trace: System.IO.FileLoadException at Microsoft.Mashup.WebViews.Windows.EdgeChromium.WebViewWindowFactory.IsRuntimeAvailable(String browserExecutableFolder)

[Stack trace deleted]





Regular Visitor

To close out the adventure, I downloaded the required version of Microsoft.Web.WebView2 from NuGet, unpacked (it is a zip file), and copied the two WebView2 DLLs to the Power BI bin folder. That worked, astonishingly. I can now connect via SSO to SharePoint and update from my Excel data source.


The needed package is here: Click Download Package on the right.


Power BI (64 bit) is in C:\Program Files\Microsoft Power BI Desktop\bin


The DLLs Microsoft.Web.WebView2.Core.dll and Microsoft.Web.WebView2.Winforms.dll need to be copied from the package to the bin folder above.

Frequent Visitor

Thanks so much chiefgeek.

I looked in my PowerBi bin folder and the 2 WebView2 DLLs were missing completely.

Think it was a bug in the May 2021 upgrade



Regular Visitor

Hi ,got the below error after adding the 2 dlls, 

Unable to load DLL 'WebView2Loader.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)


Update: worked after adding this dll from the same download