cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to publish/update apps

I'm unable to successfully update/publish any apps in our tenant. Everything behaves as usual, but after clicking update, the "Publishing app" in progress indicator just spins.. I've attempted in multiple browsers and tested from different IPs with different accounts but no success. I am able to see changes I make to reports in the app after updating, but end users are not. Strangely, end users have indicated that these changes are visible for a moment but quickly revert back to their pre-update state. I had the end users try different browsers and clear caches, etc,. but same results.

 

Example screenshot below shows the first minute after clicking 'Update', but it's still "Publishing" as I post this over an hour later. 

 

Misc. Details

Region: North Central

Premium capacity: No

 

 

App Update Hangs.gif

Status: New
Comments
Visitor

So, from my tests, fresh publishes/apps work but any sort of replacing will cause this endless loop.

 

You can pull an app down and then republish (and this seems to be the same for reports, delete datasets and publish and it works) BUT this will change the IDs for the reports/Apps so if you're using them, sigh

Visitor
@v-yulgu-msft 

Hi Yuliana,

 

Any update when this would be fixed please. Urgently need to publish report right now. Smiley Sad


Visitor

@v-yulgu-msft 

Hi Yuliana,

 

Any update when this would be fixed please. Urgently need to publish report right now. 

Member

Hi,

 

After updating to the May version of Power BI Desktop, the problem was resolved for us.

 

Frank

Visitor

We are experiencing the same issue, our users are unable to publish.  

 

At the time of writing this, the status page is still showing "No known issues: Power BI is running smoothly", when in fact we have been experiencing this issue for over 4 hours.

 

It's amazing that the relevant team takes such a long time to notice and update the status page to indicate when there are issues.  We are in the UK, about 5 hours ahead of the US,  so we lose at least half a day's work when issues occur and we have to wait (it seems) until the Microsoft US team awakens 5 hours later.

Frequent Visitor

I am also experiencing this issue today and yesterday. It would be nice for MS to alert users with a notification or sticky a post on the community boards that they are aware of the issue.

Visitor

As far as I can tell the publish is successful even though it keeps spinning. I'm hitting publish and after a minute or so closing the spinning message, then spot checking it worked. Obviously, it's a problem because we need confirmation in most cases and for releases firm-wide.

Member

I'm seeing this also. I'm already on the May 2019 update

Update 1: @v-yulgu-msft  task is NOT completing successfully. Not only does the icon spin, but also does not actually update the app. 

Update 2: somehow I expect this to clear up for us once we get the new navigation experience for apps... 

CAG Frequent Visitor
Frequent Visitor

Same issue here (North Europe)

Occasional Visitor

I am having the same issue here


@ChrisA wrote:

I'm unable to successfully update/publish any apps in our tenant. Everything behaves as usual, but after clicking update, the "Publishing app" in progress indicator just spins.. I've attempted in multiple browsers and tested from different IPs with different accounts but no success. I am able to see changes I make to reports in the app after updating, but end users are not. Strangely, end users have indicated that these changes are visible for a moment but quickly revert back to their pre-update state. I had the end users try different browsers and clear caches, etc,. but same results.

 

Example screenshot below shows the first minute after clicking 'Update', but it's still "Publishing" as I post this over an hour later. 

 

Misc. Details

Region: North Central

Premium capacity: No

 

 

App Update Hangs.gif