cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to disable Composite models

I created a report in PBI dekstop with the new preview feature enabled.  I did not plan on using the feature in that specific report,, but enabled it nevertheless.

Now I created a report that is only runnning on import (two sources, see below) which cannot be published since composite models are not yet supported. However, I am not really using a composite model. Only Import.

Capture1.PNG

I went to disable the tick box in the Preview Features (with the report open of course, and with a new save) only to learn that now I can't even open the PBIX anymore:

Capture.PNG

How can I tell PBI desktop that the file does not contain a composite model? Do I need to recreate the entire thing? I hope there is a better solution!

Best regards

Status: New
Comments
Resolver I

Hi @airfreighter 

 

i encounter the exact same trouble. Did you have an answer ? or did you find a workaround on your own ?

 

My pbix is quite an heavy one, it would take hours to do it again from scratch on Desktop RS...

 

thanks

 

Stephane

Helper I

Hello Stephane,

 

I was able to work around the issue by deleting the relationships I had established, removing the composite feature, restarting Power BI, and then recreating the relationships. The issue was that one or more of the relationships I had created while the composite model feature was enabled weren't valid when the feature was disabled. There was no warning from Power BI that one or more relationships within the model would be invalid if the feature was disabled.

 

https://community.powerbi.com/t5/Issues/Unable-to-disable-Composite-models/idc-p/475732#M29677

 

Eric

 

Resolver I

thanks for the reply, i fee a bit stupid because i couldn't see replies this morning.... So thanks for your feedback, and i'll read the other comments now that i can see it !

 

 

Helper I

No need to explain. Hopefully you're able to get this issue resolved.

 

Eric

Resolver I

yep ! thanks again

 

cheers

Frequent Visitor

Hi Stephane,

Eric is correct now all work you need to do again, especially all relationship.
After this experience I afraid to do composite model again as I was working on big project that time.


Regards/ Rakesh

Resolver I

Hi @Rakeshkrsharma 

 

the tricky thing is to be well aware of join issues. The users who built the app did some joins in both directions, i'll try to correct this with bridge tables, then it should be ok.

 

this community works like a charm, thanks to both of you guys !