Showing results for 
Search instead for 
Did you mean: 

Unable to disable Composite models

I created a report in PBI dekstop with the new preview feature enabled.  I did not plan on using the feature in that specific report,, but enabled it nevertheless.

Now I created a report that is only runnning on import (two sources, see below) which cannot be published since composite models are not yet supported. However, I am not really using a composite model. Only Import.


I went to disable the tick box in the Preview Features (with the report open of course, and with a new save) only to learn that now I can't even open the PBIX anymore:


How can I tell PBI desktop that the file does not contain a composite model? Do I need to recreate the entire thing? I hope there is a better solution!

Best regards

Status: New
Helper I

Same problem here. I enabled the feature to test if I could connect to a tabular model and pull in another data source (not possible - just like the documentation says). I then opened a different file, imported a new table (got prompted if I wanted to use direct query or import mode - I chose import), made several changes, saved, and tried to publish. I received an error saying publishing had been disabled. I then disabled the preview feature, but the file won't open:


Unable to open document

In order to open this file, the following preview features must be enabled:

Composite Models


Enabling the feature disables publishing even though all of my data sources are set to import (as opposed to direct query or dual storage mode).



Community Support

Hi @airfreighter@etheil,


Based on my test, when the preview feature composite models is enabled, get data from SQL database and local Excel files, as long as these two tables are Import. Uncheck the composite models preview feature, we can still re-open the report. 




Please check if all tables are set with Import mode like above. If issue persists, would you please record a video to show detail reproduce steps? 


Best Regards,
Qiuyun Yu 

Helper I

I tried that before posting, even going as far as deleting the table I had imported after having enabled the Composite Models feature. I also enabled loading on all tables in my model (some had the "Enable Load" option disabled) to make sure none of them had somehow been set to Direct Query or Dual; all of the tables in the file are set to Import.


I'll record a video to show what's happening.



Helper I

I figured out the issue. Even though all of the tables in my model were marked as Import, I had created bi-directional relationships that wouldn't be allowed in the model if the "Composite Models" feature were disabled. Since I had the relationships established and the  composite model option enabled, I was unable to publish to Power BI. Once I disabled the composite model option, the relationships remained and I was unable to re-open the file unless I enabled the "Composite Models" feature. 


The issue here is that even if you have "Import" set for all of the tables, you can still create bi-directional relationships between tables that aren't valid. The final solution was to delete the relationships in the model, disable the "Composite Model" feature, restart power bi, and then re-establish the relationships (fixing the relationships that were invalid). 



Advocate II



THANK YOU !! saved me a tonne of time!!!!

New Member



THANKS A LOT!!! I had the same problem. You really really saved my day.


Best regards from Mexico.

Omar Sierra

Helper II

Thank You so much.I had the same issue


Best Regards,


Frequent Visitor

Great Thanks !!

Frequent Visitor

I had the same issue, can easily be fixed by changing the relationship to 1:1 or 1:M or M:1. But M:M will not work when publishing (yet)! BTW, M:M relationship filter works great in PBI desktop and it is fantastic. Makes things simpler and removes the somewhat recurring need of creating a senior table for the sole purpose of applying a filter. Looking forward to when we can publish these models.

Frequent Visitor

Had same issue today, can't beleive after I done all of the development and then found out it can't be published.. Hoping this feature can be supported by Power BI service soon.