cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to connect to the remote server - Works on desktop but not on the portal

Hi,

 

I am trying to query Jira REST API from PowerBI and was successful on PowerBI desktop. The issue is that this particular Jira is not using corporate ID, so I had to use "Basic" authentication. I managed to get it working on desktop using both

  • Data source settings - Basic auth
  • and Anonymous auth and Power Query language - options = [Headers =[#"Authorization"="Basic abcdefghijklmno123456"]]

But no matter what I do, the data source is not refreshing after I published it to the portal.

 

When I try to refresh it online it says:

nemozny_0-1613067988894.png

 

The way it looks it seems to me your cluster is trying to access Jira from outside the firewall, which is impossible without VPN.

 

I assumed that was why you have your Gateway, but "Gateway connection" options says

You don't need a gateway for this dataset, because all of its data sources are in the cloud, but you can use a gateway for enhanced control over how you connect. Learn more

 This leaves me with no other options than to ask here... 🙂

Status: New
Comments
v-chuncz-msft
Community Support
nemozny
Regular Visitor

Thank you, @v-chuncz-msft, but that didn't help.

To be sure I tried it again now, but this is the result

  • Processing errorUnable to connect to the remote server
  • Cluster URIWABI-WEST-US-redirect.analysis.windows.net
  • Activity ID4a35d6c6-f7e1-4d02-9230-781c55dea9a3
  • Request IDff853256-05f3-4875-b074-217850725183
  • Time2021-02-15 17:17:48Z

No problem refreshing on desktop, but no success from the web portal.

nemozny
Regular Visitor

Can we confirm this is a bug?

nemozny
Regular Visitor

Hello? Is there a workaround for this bug?
On-premise gateway would do the trick, if I was able to enable it.

Victormar
Helper II

Hi!

 

I actually have the same problem and there is no way that I can make it work, any ideas?

nemozny
Regular Visitor

@Victormar you have to use/install the "on-premise gateway", there is no other way around this. The gateway acts as a middle man between your firewalled data and PowerBI servers. PowerBI server are unable to reach your data otherwise.

Victormar
Helper II

thanks! Will do 🙂