cancel
Showing results for 
Search instead for 
Did you mean: 
0

Two-part issue - bypassing visual filters with ALL(column)

Also discussed in https://community.powerbi.com/t5/Desktop/Is-this-a-bug/m-p/1088129#M503956

 

Reproduction steps:

Create the following table:

FilterColumnMeasureColumn
10
10
20
21

Create the following measure:

IgnoreMeasureColumnFilter = CALCULATE(COUNTROWS('Table');ALL('Table'[MeasureColumn]))

Create a Slicer for filtering on FilterColumn (List/Dropdown mode).

Create a Card visual that displays IgnoreMeasureColumnFilter. Assign the basic filter "MeasureColumn is 1" to the Card visual.

 

When only FilterColumn = 1 is enabled in the slicer, the card visual displays (Blank). Expected value: 2.

 

Part 2:

Continuing from above, on the FilterColumn slicer created above, enable Show "Select all" option.

Check "Select all" (so the slicer shows that both Select all, 1 and 2 is checked). Card visual shows 4 (expected)

Uncheck "Select all" so all checkboxes are empty. Then check both 1 and 2. Card visual shows 2. Expected: 4 (same as above).

Status: Delivered

Hi @MrGorkajuice 

 

This is as designed - we've updated the docs to clarify it :

https://docs.microsoft.com/en-us/dax/all-function-dax

 

 

Comments
Community Support

Hi @MrGorkajuice

 

I have reported this issue internally: CRI 188210647. Will update here once I get information. 

 

Best Regards,
Qiuyun Yu

Community Support
Status changed to: Accepted
 
Community Support
Status changed to: Delivered

Hi @MrGorkajuice 

 

This is as designed - we've updated the docs to clarify it :

https://docs.microsoft.com/en-us/dax/all-function-dax

 

 

Frequent Visitor

Thank you for looking into this, even if I was hoping for a slightly different outcome 🙂