cancel
Showing results for 
Search instead for 
Did you mean: 

Tooltip line breaks Online but not on Desktop

DesktopDesktopOnlineOnline

I have added text into the tooltip section on charts I've created to act as commentary for each chart. The text appears as expected when viewing the reports on the Desktop app. When viewing the published report online, the text seems to have a line break every other line. Screenshots attached. Has anyone else experienced this issue?

Status: Accepted
Comments
v-qiuyu-msft
Community Support

Hi @Anonymous,

 

I have report this issue internally: CRI 49240421. Will update here once get any information. 

 

Best Regards,
Qiuyun Yu 

Vicky_Song
Impactful Individual
Status changed to: Accepted
 
Anonymous
Not applicable

Thanks @v-qiuyu-msft

v-qiuyu-msft
Community Support

Hi @Anonymous,

 

Please see below information from PG team: 

 

This is a feature request - we now respect new-line characters in tooltip text. Customers were asking for it, we used to strip these characters out. Ask customer to clean their data (remove new-line chars). 

 

Best Regards,
Qiuyun Yu 

 

Anonymous
Not applicable

Hi @v-qiuyu-msft

 

I don't understand why this is a feature request rather than a bug, since it's working as expected in the Desktop app, as seen in the screenshots attached to my original comment, but not working after the report is published online? 

 

The data I have in the model is clean. There are no new line characters in the text. 

 

Regardless of whether this is classed as a bug or feature request, can you give a timeframe on when this issue will be resolved please?

 

Thanks,

Steven

Anonymous
Not applicable
v-qiuyu-msft
Community Support

Hi @Anonymous,

 

I have delivered your concern to PG team. Will let you know when I get response. 

 

Best Regards,
Qiuyun Yu 

henrikj
Advocate I

@v-qiuyu-msft

 

I've also reported this issue, at the issues linked to by @Anonymous.

 

We don't have any new-line characters at the locations were the line breaks at the incorrect location. 

 

I've posted the original string as a comment to my post: https://community.powerbi.com/t5/Issues/Word-wrap-for-tooltip-not-working-as-intended/idc-p/275690#M15755 

Anonymous
Not applicable

I've updated my Desktop app to the latest October 2017 version and now the line breaks in the tooltips are now present in the Desktop app as well as when published online...

 

There are no line break characters in the text. The data is clean.

v-qiuyu-msft
Community Support

Hi all,

 

The fix for this issue will be released in December. 

 

Best Regards,
Qiuyun Yu