cancel
Showing results for 
Search instead for 
Did you mean: 

Titles disappeared from visuals in Power BI service

Hello, this issue occurred within the past week.  Something weird has happened.  All of the titles on our Power BI visuals have been removed.  We have a report with well over 10 tabs and multiple visuals per tab - all with this issue.  In addition, we have a lot of other reports all experiencing this issue.  

Title Issue.jpg

 

 

 

Status: New
Comments
v-qiuyu-msft
Community Support

Hi @Anonymous,

 

Do you mean the title is turned off automatically for these reports on Power BI service? Is there any creators modify or republish the report recently? 

 

Please turn on the title for these visuals then check it again next day to see if title is off automatically. 

 

Best Regards,

Qiuyun Yu 

Anonymous
Not applicable

Yes, the titles were turned off without our input on all of our reports.  We use Power BI desktop to build the data model and publish, no visuals or reports.  We build all of our reports in the service and have been doing so for over a year.  We update the data model regularly republish to the service with no issue to the reports created to the service.  I enabled the new workspace settings in tenant settings around the time of the issue -could that be it? PowerBI_Tenant.jpg

 

Meghana_123
Frequent Visitor

Hi..has this issue been resolved yet i'm facing the same issue. The titles has dissappeared when i republished the report .

Anonymous
Not applicable

Unfortunately, the issue has not been resolved.  We are slowly adding back the titles manually.  Power BI team, can you explain why the titles may have disappeared in the first place?  So, we can avoid in the future? 

Anonymous
Not applicable

Are there any updates on this? The same thing has just happened to me, it's very distressing... 

 

Edit: I don't know if this will help anyone, but I was still seeing the titles in my report as expected when I exported it to PBI Desktop, so I was able to republish from there and get them back. I technically had always had them though, it was just a question of whether I was seeing my formatted, friendly titles or the system-generated ones.

v-qiuyu-msft
Community Support

@Anonymous I have created a report in desktop without any visuals then publish it to the new preview version workspace, create a report from this dataset on service, turn on title of table visual. After I republish the report, the table visual title still here. As I'm not able to reproduce the issue on my side, I would suggest you create a support ticket to let engineer look into your environment. 

 

Support Ticket.gif

 

@Meghana_123 @Anonymous Do you create visuals on Power BI service rather than Power BI desktop? Would you please share detail steps for us to reproduce the issue? 

 

Best Regards,
Qiuyun Yu 

Anonymous
Not applicable

Hi, this is still an issue.  My team and I are simply going to reconfigure the titles for our visuals.  

v-qiuyu-msft
Community Support

Hi @Anonymous,

 

It's better to let Microsoft support engineer look into your environment to see if it's Power BI service issue as suggested in my previous post. 

 

By the way, instead of creating the visuals on Power BI service directly, I would suggest you create these visuals in Power BI desktop, so we can have backup of the pbix file to avoid unexpected issue on Power BI service. 

 

Best Regards,
Qiuyun Yu 

Anonymous
Not applicable

Hi Group just noticed this on the Power BI support page:

 

"Some customers may notice certain formatting features, like specific data point colors or custom Visual Title formatting, revert to default in their reports. This happens after changing any report-level settings in the Report Settings Blade, or through the Options dialog in Desktop followed by publishing to the service. A fix is being deployed and will be in all regions by end-of-day 11/9/18."

 

Did I find a Power BI bug?  That is so cool!

v-qiuyu-msft
Community Support

Hi @Anonymous,

 

Thank you for your sharing. You can keep an eye on the status of this issue on Support page, test it again to see if issue still there after the message is removed. 

 

Best Regards,
Qiuyun Yu