cancel
Showing results for 
Search instead for 
Did you mean: 

This API call has quit working in the last GET https://api.powerbi.com/v1.0/myorg/reports

Calls to GET https://api.powerbi.com/v1.0/myorg/reports quit work correctly until last month.  In the past, calls to this API returned the reports that a user had access to.  The direct shared reports, the reports the user had access because of group membership on actual report, the workspaces the user had at least view rights on or was in a group that at least had view rights and the the user's own reports,. 

 

Now the API returns only the reports that are direct shared and owned and not even all of those but a subset, it seems only from workspaces newly created, reports from the older upgraded workspaces are not coming showing.  Access of the reports can be easily proven by using the "Shared with me" of app.powerbi.com or pasting a link to the report.

 

 

Status: Investigating

Hi @fosters4him ,

 

It may be affected by the old workspace upgrade, are you expecting it to get the same feedback as before?
I may not have a good understanding of your needs.

 

Best Regards,
Community Support Team _ Caitlyn

Comments
v-caitlyn-mstf
Community Support
Status changed to: Investigating

Hi @fosters4him ,

 

It may be affected by the old workspace upgrade, are you expecting it to get the same feedback as before?
I may not have a good understanding of your needs.

 

Best Regards,
Community Support Team _ Caitlyn

fosters4him
New Member

I thought the same thing on the upgraded workspaces, while if they don't work that is an issue in itself, not a small task to correct either, with 100's of reports in multiple workspaces, with 100's of authorizations, creating new workspaces would be a huge job.

 

So I created new workspaces and shared out some reports, same results, it is as if the API call no longer returns all reports a user has access to. The example PowerBi Embed on Github seems to imply that by having you pick a workspace and then retrieve the reports in it.  The command is still there it just does not return what it use to return. The older PowerBI Embed examples showed explicitly how to get the reports a user has access to, that being the API command in the title of this issue.