cancel
Showing results for 
Search instead for 
Did you mean: 

The credential stored in the Cloud is missing / can't refresh

errorJPG.JPG

I'm getting this error since yesterday on a new dataset. It is a simple excel file table. I've done the following.

Signed out of Power BI Desktop and back in

Got the latest personal gateway

turned the gateway service off / on

republished multiple times during this process.

 

Others seem to be having the same issue. see thread here

There is a current support site error message, but it is specific to SharePoint as a data source only.

Status: Accepted
Comments
Helper II

I'm getting the same exact error. My data model is more complex than an excel file, but the same error none-the-less. I've removed the data set and reloaded it back in, still the same error.

New Member

Getting the same error as well.  Using both SQL Database Connection and Excel workbooks in this particular one. 

Regular Visitor

I hae the same issue. Cannot refresh credentials. Seems to be a js error in the browser. When I click to expand "Data Source Credentials", I get the error below in the Developer Tools console.

 

 

ai.0.js:1 AI: USRACT_StringValueTooLong message:"string value is too long. It has been truncated to 1024 characters." props:"{value:TypeError: Cannot read property 'value' of undefined\n at Object.T [as getDatasourceDisplayName] (https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.common.bundle.min.js:17:26341)\n at S (https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.common.bundle.min.js:17:23318)\n at Object.s [as convertDiscoverAggregatedDatasourcesResponseToDatasources] (https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.common.bundle.min.js:17:18040)\n at services.featureSwitchService.featureSwitches.isSovereignCloud.hasDmtsPersonalGateway.r.shouldUseDMTS.c.getAdmsAggregatedDatasourcesForOneModel.then.t.scope.showDiscoverDatasourcesSpinner (https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.web.bundle.min.js:47:24109)\n at https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.dependencies.bundle.min.js:149:20\n at m.$eval (https://app.powerbi.com/13.0.1700.762/scripts/powerbiportal.dependencies.bundle.min.js:163:347)\n at m.$digest (https://app.powerbi.com/13.0.1700.762/scripts/}"u.warnToConsole @ ai.0.js:1u.throwInternalUserActionable @ ai.0.js:1t.sanitizeString @ ai.0.js:1t.sanitizeProperties @ ai.0.js:1i @ ai.0.js:1r.trackEvent @ ai.0.js:1t.trackEventInternal @ powerbiportal.dependencies.bundle.min.js:955t.endTimedEvent @ powerbiportal.dependencies.bundle.min.js:955t.logEvent @ powerbiportal.dependencies.bundle.min.js:955e.logEvent @ powerbiportal.dependencies.bundle.min.js:955t.logEventInternal @ powerbiportal.dependencies.bundle.min.js:956t.logEvent @ powerbiportal.dependencies.bundle.min.js:956(anonymous function) @ powerbiportal.common.bundle.min.js:20(anonymous function) @ powerbiportal.dependencies.bundle.min.js:149$eval @ powerbiportal.dependencies.bundle.min.js:163$digest @ powerbiportal.dependencies.bundle.min.js:160$apply @ powerbiportal.dependencies.bundle.min.js:164(anonymous function) @ powerbiportal.dependencies.bundle.min.js:156e @ powerbiportal.dependencies.bundle.min.js:63(anonymous function) @ powerbiportal.dependencies.bundle.min.js:66

Regular Visitor

I am having the same issue.

Microsoft

Hi All,

 

There is already an existing issue reported internally to Power BI Team: CRI 27418567

I’ll keep an eye on it and post here once there is any update.

 

Best Regards,

Herbert

Advocate II

I'm still having the same issue. So sad 😞

Regular Visitor

I'm having the same problem. I hope the solution is urgent because I can not update my deshboards

Impactful Individual
Status changed to: Accepted
 
Helper I

Hello All ,

 

Have just posted another topic on the same issue, I am using a mixture of SQL database and excel. I have one dashboard that is refreshing daily as scheduled. Another dashboard that use the same data sources keeps coming back with this error. I have followed all of the suggested steps with no joy.....

 

 

Regular Visitor

San Francisco Checking in with same issue... 

Data source type
Processing error The credential stored in the cloud is missing.
Cluster URI WABI-WEST-US-redirect.analysis.windows.net
Activity ID c648e05b-d0e8-488b-b7ae-e4a0d522f842
Request ID d7b3073d-fdae-5296-934a-4c731bf7c8c7
Time 2016-12-14 02:48:16Z