cancel
Showing results for 
Search instead for 
Did you mean: 

Support for Cloud-based PDF files without requiring an On-premises data gateway

In the blog post announcing the April 2019 release of Power BI Desktop, the section on the PDF Files connector mentioned:

 

"Support for Cloud-based PDF files (without requiring an On-premises data gateway) is also coming later this month."

https://powerbi.microsoft.com/en-us/blog/power-bi-desktop-april-2019-feature-summary/#pdf

 

I've just found out (via a support ticket and simple repro) that in fact that support is still missing.  Can that please be fixed ASAP?

 

The symptoms are: you build a Power BI Desktop solution including PDF files from a cloud source (e.g. SharePoint or a web site) and it refreshes fine. But after publishing to the web service, your web service refreshes will crash with a really awful message. It seems to indicate the developers messed up their build, e.g. 

 

Could not load file or assembly 'Microsoft.ProgramSynthesis.Extraction.Pdf, Version=6.19.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference.

Status: New
Comments
Regular Visitor

Hi Mike. The scenario you describe should be working. The error you're getting looks like a bug/regression in the Power BI service. Please follow up with the support folks to ensure it's getting the appropriate attention.

 

Ehren

Advisor

@Ehren - I agree. I've already been down the support road on this topic, they said they discussed the "ETA" (I presume they mean when it will be fixed) with "the Product team". 

 

The proposed workaround was to use the gateway, but that is not working either (and would be a very expensive solution - needing a new VM).

Moderator

Hi @mike_honey

 

It looks like you already opened a support ticket to Microsoft, right? 

 

If it is, please keep contacting with ticket owner to get help. It would be better if you could share the solution here once the issue is resolved. 

 

Best Regards,
Qiuyun Yu

Advisor

No further info from Microsoft Support, they arbitrarily closed the case.

 

But anyway I kept a test PBIX going on scheduled refresh and in recent days it seems to have started working. I turned on scheduled refresh on my actual PBIX and that has worked also.

 

Has this issue been silently fixed?  Interested in anyone else's results.

Regular Visitor

Hi Mike. Yes, my understanding is that this issue has been fixed (although it would have been good for you to hear this from support directly).

Ehren

Advisor

Hi @Ehren , thanks for confirming.