cancel
Showing results for 
Search instead for 
Did you mean: 

Subscribing does not do any action

Hello,

 

we are testing PowerBI Pro in 60-days trial version. We set up "on-premises data gateway (personal mode)" and we set up scheduled refresh of dataset, what actually works. I set up few reports and dashboards and I subscribed them and PowerBI wrote me that it will send me reports and dashboards to my mail with next data refresh, but maximally once per day. But there is some problem with this, because I have never got any email with dashboards or reports.

 

Am I doing something wrong or is there necessary some special configuration? Or where could be a problem?

 

Thank you.

 

JS

Status: New
Comments
Moderator

Hi @janschovanek,

 

Please check if the dataset has been refreshed successfully after you create a subscribe. Based on my test, after create a subscribe for a report, after the related dataset is refreshed, we can receive the email. 

 

If dataset is refreshed but no email, please run Fiddler trace with below option enabled. Then repeat the steps to create a subscribe, refresh related dataset via Refresh Now to capture fiddler trace. You can upload .saz file to your OneDrive or Dropbox and share the link here. 

Fiddler.PNG

 

Best Regards,
Qiuyun Yu

Visitor

Hello,

 

thanks fo reaction, but I am not sure I would like to send any decrypted HTTPS communication from 3rd party software to anyone outside our company, the main problem is that I'm not sure how would this helps to this solution. Isn't there any other way how to helps me?

 

Actual situation:

Yesterday i set up scheduled refresh for today, what has happened correctly. I can see actual data in my refreshed dataset. But I still haven't recieved any email from subscribed dashboards/reports. I tried to delete all subscribtions and set them again and refresh data manually. Refresh worked, but there is still no email.

 

BTW: I recived email about failed scheduled refresh yesterday due to not having computer online, so I guess there isn't problem between email communication, I guess there would be some problem of triggering the sending email from PBI.

 

Questions:

1) Is there any log in PBI, where could I see something like "at 11:04:38 PBI sent email notification to xxx@xxx.cz ? 

 

2) Couldn't be there problem with NOT having Office 365 domain in our company?

 

3) I found PBI users have same problem while their UPN isn't same as their email adress. Can this be also my problem? What UPN really is, how can I find my UPN and can I eventually influate this situation?

 

Additional:

We decided to have some BI tool as a company and we are now finding tool which would be ideal for our needs and one of our needs is sending reports/dashboards in regular frequency so this topic is really important for our final choice of BI tool.

Visitor

Anyone? Anything?

Moderator

Hi @janschovanek,

 

Please ensure that your User Principal Name (UPN) is able to receive emails according to this article: https://docs.microsoft.com/en-us/power-bi/service-report-subscribe#considerations-and-troubleshootin...

 

Fiddler is a good tool to capture backend traffic during the time you reproduce the issue. You can upload captured .saz file to your Onedrive and sent the link in private message to me. 

 

Best Regards,
Qiuyun Yu