cancel
Showing results for 
Search instead for 
Did you mean: 

Strange Percentage Value Behaviour

PercentageBehaviour.png

 

 

Hi all,

 

The three tables are all showing data with the same filters.  You can see the bottom table shows the values by status, which matches what I see in Excel.  But as soon as I remove the status, the overall value for %1 remains the same but the individual values by year jump up to values that are much higher (76%, 79%) than the average (45%) which looks very odd.

 

Also odd to me, though I am guessing it is due to the rows with no measure values [?], is the below: a table by year and course without headcount, a table by year and course with headcount (which always has a value -- hence the 2 extra rows) and a table with year (and not course).  Different %1 and %2 values.  Can you help me understand this?  Again, I realise Power BI and Excel are different products by Excel seems consistent here.PercentageBehaviour3.png

Thanks for your help and this forum; they're greatly appreciated.

Ian.

 

Status: New
Comments
Community Support

Hi @IRHolder

 

It should be related to the DAX of measure. It would be better if you could share pbix file with us. Please do remove sensitive data then upload it to your OneDrive, paste the share link here. 

 

Best Regards,
Qiuyun Yu

Helper I

Thanks Qiuyun; I'll see what I can do.  What do you mean by "remove sensitive data"?  I'm connecting to a cube and those measures are calculated in the cube -- but in Power BI they are different from the values if I used an Excel pivot table.

Helper I

Hi @v-qiuyu-msft 

 

Something else to add: I am getting strange results with drill-down on this value.

 

Between the top-level and the drill-down, the values change.

TopLevel.pngDrillDown.png

You can see the totals stay the same, but the year values change.

Community Support

Hi @IRHolder

 

Did you connect to cube in a live connection or import mode? If you import data to the report, please share pbix file with us. Do remove sensitive data in the report, upload it to your OneDrive then paste the share link here. As the the forum is public, please ensure you don't share private data. 

 

Best Regards,
Qiuyun Yu

Helper I

Hi @v-qiuyu-msft ,

 

That was with a live connection.  Let me see what I can do with an import.

 

Thanks,

Ian.

 

Helper I

Apologies...seems to have been an issue at our end.  The data now matches.  Our development team suggested caching as an issue [?].