cancel
Showing results for 
Search instead for 
Did you mean: 

Standard visual data labels conditional formatting doesn't work in power bi service when published

Hi,

 

Is there an ongoing maintenance in the service today? Yesterday my visuals are working fine but now the conditional formatting doesn't work anymore.

 

I have applied a conditional formatting on data labels on a line and clustered column chart in my report. It works fine in the desktop but when I publish the report in the service the labels got messed up. See below screenshots.

 

Power BI Desktop:

genaro_custorio_0-1662524344687.png

 

Power BI Service:

genaro_custorio_1-1662524414973.png

 

Many thanks in advance for any help on this.

 

 

Best,

Genaro

Status: Delivered

Hi @genaro_custorio 

I am so glad to hear that your issue has been solved . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Ailsa-msft
Community Support
Status changed to: Investigating

Hi @genaro_custorio 

Does it appear normal now ? I tested it in my Desktop and Service , it seems normally . Recording 2022-09-09 at 14.56.05.gif

Recently Service has been updated, but it is about the app, and I have not received an issue about conditional formatting. Maybe you can clear your broswer cache and republish the report to Service from Desktop.

 

Best Regards,
Community Support Team _ Ailsa Tao

 

genaro_custorio
Regular Visitor

Hi, @Ailsa-msft.

 

Thanks for investigating this. I have cleared both my power bi desktop and browser cache but the issue is still there.

 

Thanks,

Genaro

Veliaya
Frequent Visitor

Hi, @Ailsa-msft ,

 

I have same issue on data label in power bi

 

Here my screenshot in power bi desktop :

(the font color applied with conditional formatting)

Veliaya_0-1663165107292.png

 

and this is my screenshot in power bi service :

Veliaya_1-1663165161662.png

 

please investigating this asap, i have tried everything : clear chache, create new project, change hex code, change data label design, re-install power bi desktop and microsoft edge. but the issue is still there from wednesday last week.

 

thanks,

Velia

 

 

Veliaya
Frequent Visitor

Hi @Ailsa-msft ,

I have updated from aug to sep 22, but issue is still there

Ailsa-msft
Community Support

Hi @genaro_custorio 

Service has recently been updated , you can test your problem to see if it still exists .

 

Best Regards,
Community Support Team _ Ailsa Tao

Veliaya
Frequent Visitor

Hi @Ailsa-msft , the problem still there on my pbi desktop sept version. i can't change my data label based on field value

genaro_custorio
Regular Visitor

Hi @Ailsa-msft,

 

It seems that the issue has been resolved in both desktop and service. Thanks for all your assistance on this.

 

Best regards,

Genaro

Ailsa-msft
Community Support
Status changed to: Delivered

Hi @genaro_custorio 

I am so glad to hear that your issue has been solved . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

genaro_custorio
Regular Visitor

Hi @Ailsa-msft,

 

Apologies, I spoke too soon. I thought the issue has been fixed in the service as well but the data labels conditional formatting still doesn't work there. It's working fine in the desktop but not in the service. Can you please re open the ticket and investigate further?

 

Thanks,

Genaro

Veliaya
Frequent Visitor

Hi @genaro_custorio ,

 

I have this verison of pbi desktop and still have the issue. How about you?

 

Veliaya_0-1664754432592.png