cancel
Showing results for 
Search instead for 
Did you mean: 

Slow Dataflow Refresh

Hi Everyone

 

Is anyone experiencing slow dataflow refreshes? Since this morning, I have a dataflow that is taking very long to refresh. I haven't edited the dataflow for at least a month and it has been working fine up to now.

 

A simple text-inputed table (4 rows, 2 columns) took 15 minutes to update. Another similar table took 27 minutes to update. Both of these tables are not linked to an external data source and should usually take 30s to refresh. I cancelled the refresh after about 2h30. The dataflow was not even half-way through a refresh that normally takes 20 minutes.

 

I aborted the second attempt at refreshing the dataflow after about an hour and the first table (text-inputed, 3 rows, 2 columns) had not yet refreshed.

Status: Delivered

Based on the discussion in this post, It looks like an issue happened in specific region Europe and it has been fixed up to now. If there is still someone has this issue and it's continuous in the case of  simple table structure and not very large data amount, please consider opening support ticket for further help. 

 

Best Regards,

Community Support Team _Caiyun

Comments
matteoumbri
Frequent Visitor

Confirm that the issue appears fixed now, I just manually triggered dataflow refreshes, and they all got completed successfully

martin_sperling
Regular Visitor

Yes, same on our side. Problem seems to be fixed.

v-cazheng-msft
Community Support
Status changed to: Delivered

Based on the discussion in this post, It looks like an issue happened in specific region Europe and it has been fixed up to now. If there is still someone has this issue and it's continuous in the case of  simple table structure and not very large data amount, please consider opening support ticket for further help. 

 

Best Regards,

Community Support Team _Caiyun

EP1
Advocate IV
Advocate IV

@v-cazheng-msft I can confirm that the issue is resolved on my side too. Thanks!

v-cazheng-msft
Community Support

@EP1 

 

Thanks for your feedback. That's great! 😀

 

Best Regards,

Community Support Team _Caiyun

TI_JARDINES
Regular Visitor

Hi everyone:

 

I have the same problem here in Peru, is in all the servers of Microsoft.

😥

MunroA7
Advocate III

@v-cazheng-msft So the dataflows are refreshing but I've got the old problem back where new data is showing in the dataflow but not in my desktop/pbix.  The new data simply isn't visible.  So might want to check your datasets are right when creating reports if dataflows are the source.  This happened last time they stopped working.  I've got a ticket raised but it now means I can't author new reports or keep existing ones updated which just isn't acceptable.  Whatever they did to fix it last time needs to be re-done.

PowerGünni
New Member

Morning Folks,

still having this problem with a relative huge SQL Database Report. Any idea how to fix this? 

Gateway and PowerBI are on the recent verison. 

 

Kindly Niclas

v-cazheng-msft
Community Support

Hi @PowerGünni 

 

You mean your report created with data from a huge SQL database and then the refresh is slow, right?  Is your dataflow refreshed fast before but become slowly suddenly like others in this post?

 

Best Regards,

Community Support Team _Caiyun

PowerGünni
New Member

Hi @v-cazheng-msft,

yeah. I can totally agree with that. 
Currently it's like you described it. 

Out of sudden the refresh was really slow. 

Kindly

Niclas