cancel
Showing results for 
Search instead for 
Did you mean: 

Slicers are not showing drop-down values directly under visual

This bug started happening to me in the Power BI Service yesterday in Chrome, and to my coworker today in Edge. When I click on a drop-down slicer to select a value, the list appears way off to the side instead of directly under the visual. Screenshots are attached. If a slicer is off to the far right of the page, the drop-down list won't appear at all as it's been "shifted" to a location off screen.

 

Changing the browser window's size will shift the drop-down location, but it's never exactly where it should be. I checked and confirmed my Chrome browser is up to date, installed the latest Power BI and Windows updates, rebooted my machine, and deleted my cache, but the issue persists. Any help is appreciated.

 

2021-09-03 13_55_05-Weekly Summary - Power BI.png2021-09-03 13_56_07-OWP Dashboard - Power BI.png

Status: Delivered
Comments
glgaraffa
Regular Visitor

Same issue here, browsers below:

 

Chrome 93.0.4577.63 (64-bits)

Edge 93.0.961.38 (64-bits)

 

It only works if you change the view to actual size, but that won't work for all reports we have, so this have to be fixed.

 

jhills
Advocate I

Received an update from support on my ticket. The bug has been identified on the Chromium side.

 

"While the issue is not originated from Power BI, our Engineering team has managed to develop a code that will fix the issue, and they are expediting the deployment to reach Power BI Service as soon as possible."

 

 

v-chuncz-msft
Community Support

@KG_3243550 

 

To check the latest status for this known issue, you may keep an eye on the Awareness.

Power BI customers using Edge or Chrome V93 web browsers with the default page scale set to 100% may experience UI behavior issues when interacting with common web page controls, such as dropdown slicers, date pickers, or line charts. As a workaround, users can use the zoom setting of anything other than 100% which forces the browser to behave normally. Engineers have identified root cause, and an estimated time to mitigate will be provided shortly.

Anonymous
Not applicable

Facing the same issue pls resolve this asap .

deefens
Frequent Visitor

I see one more issue beside of slicer options not being set correctly. When a slicer has header off, but title on, it draws a big fat border around that slicer box, although border is either disabled or set to zero.

 

Top is from PBI Service, bottom from PBI Desktop. The bottom one is how it should look like (and always looked like until the issue came up):

 

Screenshot 2021-09-14 142753.png

 

Peterdstraw
Frequent Visitor

@deefens, I've just noticed this is happening with cards as well. Not sure if it's part of the same issue or not but seems to have happened at the same time.

deefens
Frequent Visitor

@Peterdstraw It showed up for me today the first time (same as the rendering issue with slicers), so I assume it's related. Just tested it with a old chrome version, and there it's also messed up. And the same report on PBI Reportserver renders just fine. So it must be a Power BI Service Issue.

chross
Advocate III

@deefens @Peterdstraw I noticed the same thing today with the borders on the cards and slicers looking weird (it's ugly actually!!).  I hope they fix these issues soon!!! 

deefens
Frequent Visitor

Would be helpful if someone from MS could give a short approval if this is a server side issue, so we wouldn't need to chase that issue somewhere locally.

chross
Advocate III

@deefens  I know it's so frustrating.  It's rare that they ever post on the support page, but they did update it yesterday.

 

https://powerbi.microsoft.com/en-us/support/