cancel
Showing results for 
Search instead for 
Did you mean: 

Slicer switches from Dropdown to List when using Bookmarks

Hello,

I have a Dropdown slicer (built-in visual, not custom) on my page and I've created two bookmarks.

When I switch to another bookmark (using image with action) - then suddenly my slicer switches to a List instead of Dropdown.

And it stays like this even if I return to an original bookmark.

Looks like a bug - please fix

Thank you

Michael

Status: New
Comments
Anonymous
Not applicable

This bug (yes bug) is quite annoying.

 

I've managed to create a filter menu which you can hide and unhide on a report page which hugely increases the UI of the report.

 

However, this is completley let down by the fact that the slicers 'change' their formatting making the filter menu look unprofessional.

 

I wouldn't have thought it was a big fix??

 

Sort it.

imranamikhan
Helper V

Hi @Anonymous,

 

@EduSurveys suggestion seems to work for now and that was similar advice from the microsoft support team. I have also updated the other thread with more details if that helps.

 

https://community.powerbi.com/t5/Issues/Slicer-switches-from-Drop-down-List-to-Check-List-when-using/idc-p/1150737#M57887

 

Regards,

ImranAmi

RJSH_GreatBear
Regular Visitor

If it helps; I came accross the same problem and can work around it - it looks like a bug.

 

To recreate issue:

If you have the 'Display' option selected on the bookmark (...) it should remember how the page looks.

 

After you create the bookmark (with slicers set to be drop down lists), clicking on the bookmark will then change the dropdowns to lists instead.

 

PBI seems to "forget" to record the actual display state of the slicers when the bookmark was initially created, and instead reverts to the list slicer default.

 

Workaround:

If you click (...) on next to the bookmark and select "update" it seems to reaffirm the state correctly and solves the issue.

MKE
Frequent Visitor

@RJSH_GreatBear  Yeah that works. It is a step a person can easily forget when setting up bookmarks and having slicers that apply dropdowns. Had a similar problem and this trick fixed it.

 

Sanket_Pol
New Member

It wasn't working for me at first as well, but then it worked after I changed the format and in settings of slicer clicked "Update" and it worked