cancel
Showing results for 
Search instead for 
Did you mean: 

Slicer Visual not displaying properly between desktop and online

I encountered a small probelem with the slicer visual. in desktop version it looks like draggable line(sequence of numbers between 1 and 100. I and specify lower limit and upper limit. works great. Online though, after ai publish the report, the visual changes and each numeric value is clickable selectin box. not a line any more.

 

How can I make the slicer visual display consistent between Desktop and Online?

 

PowerBI Desktop.pngPowerBI Online.png

Status: Accepted
Comments
Microsoft

@Sam4u

 

I can repro the same issue as you. I've reported it internally to Power BI Team: CRI 36809152
I'll post here once I get any update about it.

 

Best Regards,
Herbert

Impactful Individual
Status changed to: Accepted
 
Power BI Team

Hi - thanks for reporting this. It's an issue with the way numeric slicer is created as a 'Preview' feature. If you click the dropdown to the right of the 'Health Index' header, you can change the mode of the slicer. if you change it to List and then change back to the range, it'll fix the type and should show the same sort when you publish it.

 

Please let us know if that fixes it for you, or if you still have a problem!

Thanks!

New Member

Thanks for the tip.   I had the same problem and your solution worked.

New Member

Hi all, 

 

i have the same problem but there is no option to change the slicer mode from the drop down. 

The only options are: export data, see data, spotlight and sort by (in my example...) "contract monthly" 

 

The slider should display 0 to 11,000 etc..... 

 

works fine in desktop but when published only get the tick boxes, which is not practical when dozens of values are involved..

 

Any help greatly appreciated.!

 

Thanks

 

A

 

Frequent Visitor

Not sure if that will help you, but go to your table and make sure that you have only numbers in that column. Make sure you dont have any numbers formated as text, no empty cells, special characters like # sign etc. 

I think the desktop aplication is more forgiving and if you have number formated as text it still recognizes as number, but online if it encouters even a single cell that is not a number, it doesnt kno whow to treat it and does not display the slider, but only the boxes

Power Participant

I'm seeing the exact same behaviour. Desktop version is latest: 2.55.5010.641 64-bit (February 2018).

 

When will this issue be actually resolved (without requiring the workaround) ?