cancel
Showing results for 
Search instead for 
Did you mean: 

Sharing via hyperlink on Powerpoint doesn't work, copy the link does - previous solution stop workin

Hello everybody,

 

my question is regarding the sharing report via hyperlink. We put the link into PPT presentation, once we click on it, we get the log in page, and then the browser opened our Powerbi homepage, not the Report.

When we copy-paste the same hyperlink into the browser, it works as it should and the specific report is opened.

 

We would like to have the option to click on hyperlink and open specific report from a powerpoint presentation. 

 

On a previous post ( @Greg_Deckler ) the solution was to add either ?noSignupCheck=1 at the end of your URL or &noSignupCheck=1. This solution worked fine for a period of time but now it does not work anymore. It takes us to this page "https://app.powerbi.com/signinredirect".   

Even the "view in powerbi" link generated by powerbi service when you export a report to powerpoint does not work

 

 

I've tried to solve through community help but I've been suggested to post here. https://community.powerbi.com/t5/Service/Sharing-via-hyperlink-on-Powerpoint-doesnt-work-copy-the-li...

 

I've already tried with edge and chrome. Both Browsers with cache cleared.

Also many collegues of mine have tried and they have the same issue.

I'm starting thinking that our log-in sistem might be the problem. we have a corporate log-in system with our own log-in page.

please help
thank you
alberto999_0-1652822692182.png

 

Status: Investigating

Hi @alberto999 

Based on the above information, if you are a Power BI Pro licensee, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.

It would be great if you continue to share in this issue to help others with similar problems after you know the root cause or solution.

The link of Power BI Support: https://powerbi.microsoft.com/en-us/support/

For how to create a support ticket, please refer to https://community.powerbi.com/t5/Community-Blog/How-to-create-a-support-ticket-in-Power-BI/ba-p/6830...

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Ailsa-msft
Community Support
Status changed to: Needs Info

Hi @alberto999 

So what you mean is, if you share the report and get a link, you can jump to the corresponding report by opening the link directly in the browser, but copy the link to the PPT, and then open it in the PPT to be the home page of the Service face, rather than the corresponding report ? Similarly, if you export the report to PPT, the hyperlinks inside cannot jump to the corresponding report ?

 

Best Regards,
Community Support Team _ Ailsa Tao

alberto999
Regular Visitor

hi @Ailsa-msft, thank you for your quick reply.

Exatly.

Copy-paste link in browser works fine, we land to the specific report.

 

Copy-past the link in a PPT and than clicking it, we first go to a log-in page (even if we are already logged to PBI service) and than, after log-in, not to the specific report but to our PBI Post log-in  Home Page; 

 

just to be more precise, we land to a log-in page that starts "https://app.powerbi.com/singleSignOn?route=groups" (I've attached a screenshot of the page)

I insert my mail (I'm not Prompted to insert my Password) but than we do not land to the specific report but to our PBI Post log-in  Home Page. 

 

 

alberto999_0-1652863053840.png

 

We have the same issue with the link that is automaticly generated by exporting a report to PPT (in the first page you get a "view in powerbi" link ) ;

This morning I've tried also Word and Excel. we havre the same problem as with PPT

 

In addition, if we copy paste the same link in a e-mail message (outlook) and than open it it works perfectly (we reach the specific report without the necessity to pass to the log-in page)

 

thank you for your help

 

Best regards

Alberto

 

Ailsa-msft
Community Support
Status changed to: Investigating

Hi @alberto999 

Based on the above information, if you are a Power BI Pro licensee, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.

It would be great if you continue to share in this issue to help others with similar problems after you know the root cause or solution.

The link of Power BI Support: https://powerbi.microsoft.com/en-us/support/

For how to create a support ticket, please refer to https://community.powerbi.com/t5/Community-Blog/How-to-create-a-support-ticket-in-Power-BI/ba-p/6830...

 

Best Regards,
Community Support Team _ Ailsa Tao