cancel
Showing results for 
Search instead for 
Did you mean: 
0

Schedule Refresh is not showing my data gateway as online.

Hi,
I am trying to schedule the refresh for my dataset: Edge_PDF_Reliability.
When I am trying to select the datagateway it showing its offline.
While for other dataset of mine, it is showing me the datagateway in list. Need help asap.
 
Use a data gateway option is disabled.
Issue_PowerBI_1.JPG
While with other dataset, option to select data gateway is enabled.
Issue_PowerBI_2.JPG
 
Even Refresh is not working, here are the details.
 
Activity ID4bb85c24-bed6-4b48-8adb-f3a3c317080d
Request ID2a9e04a7-13c3-cd3c-bf06-3d818d555831
Correlation ID5b66831d-8d44-4dd7-b5d9-e432fd5641bb
TimeTue Feb 14 2017 14:45:27 GMT+0530 (India Standard Time)
Version13.0.1700.1239
Status: Delivered
Comments
Super Contributor

@gunjansa

 

Have you installed the personal gateway on the machine where your dataset locates?

If you want to use on-premises gateway, have you installed and configured the on-premises gateway for this dataset? You can see the on-premises gateway status and add data sources in “Manage Gateways”.

 

Best Regards,

Herbert

Established Member
Status changed to: Needs Info
 
Visitor

I have caught the problem. But still not able to figure out the correct solution.

My dataset contains 2 SQL tables and one table from Kusto Cluster.

Normally, Kusto cluster does not require any data gateway. It simply uses Web in Data Source Credentials.

 

Previously, it was not showing my data gateway. Once I added the Kusto Cluster in my data source it started showing Gateway when I was trying to schedule refresh. Hence, above problem is resolved for now Smiley Happy

But there is new problem. Refresh is failing with below message.

I have already tried it giving "https://ptpedge.kusto.windows.net/" as URL and also altered the credentials from Anonymous/Basic/Windows. But this is not helping Smiley Sad

 

Underlying error code:-2147467259
Underlying error message:The credentials provided for the Web source are invalid. (Source at https://ptpedge.kusto.windows.net/v1/rest/query.)
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.CredentialError.DataSourceKind:Web
Microsoft.Data.Mashup.CredentialError.DataSourcePath:https://ptpedge.kusto.windows.net/v1/rest/query?db=Edge&csl=.show%20version
Microsoft.Data.Mashup.CredentialError.Reason:AccessUnauthorized
Cluster URI:DF-MSIT-SCUS-redirect.analysis.windows.net
Activity ID:4bb85c24-bed6-4b48-8adb-f3a3c317080d
Request ID:36bba14b-5c87-cb27-64df-73ac8b4f89f2
Time:2017-02-16 09:35:59Z
Visitor

Any updates on this issue.

How do we have SQL Tables and Kusto Cluster Tables together in a data gateway??

Super Contributor

@gunjansa

 

If the gateway is configured properly and shown as online, the refresh should work well.

I suggest you to create a support ticket at http://support.powerbi.com (see bottom of page) since it may be account specific.

 

Best Regards,

Herbert

Established Member
Status changed to: Delivered
 
Visitor

@v-haibl-msft I don't think its account related problem.

Yes datagateway is showing online. Even all connections are successful.

I believe here is the problem. For Kusto, I have to give DataSource Type as Web.

And Kusto Cluster works on OAuth. In data gateway I am not seeing this option.

While if I give Kusto cluster directly in Web Credentials it shows OAuth.

But here I need to give in data gateway because I have SQL Tables too in the same datasource.

Please find the below screenshot. Let me know if there is any fix or my account needs special authorization for this.

 

DataGatewayFailure.JPG

 

 

Member

Hello,

Can someone confirm if Kusto cluster data source needs a gateway?  I'm suspecting no since it is cloud based authentication.  If so, just wondering is there documentation on which data sources requires gateway, which ones don't?

 

Your help is much appreciated.

-JL