cancel
Showing results for 
Search instead for 
Did you mean: 

Salesforce data refresh with invalid credentials

Hi,

 

I've been experiencing an issue where I cannot refresh the dataset from the Saleforce data source in the Power BI service. While I am in Power BI desktop I am able to refresh the data without issue. While I am in the Power BI service, if I navigate to Settings > Datasets > Report Dataset Credentials, I am shown an error that tells me that the credetials are not correct. Even attempting to re-enter the credentials from this page does not allow the account to accomplish login.

 

First I select Settings > Datasets > Report.  You can see below the salesforce credentials are not working correctly.

 

1.jpg

 

I then click on edit credentials next to sales force and this is the pop up. OAuth2 is the only authentication method possible to select.

 

2.png

I click sign in and this pops up.  I then type in the username and password and click login.

 

3.png

After I click login I get this error that pops up.

 

4.png

 

The entered credentials are correct and should not return an issue.

Status: Accepted
Comments
Super Contributor

@JoshuaHoward

 

Same issue was reported internally to Power BI Team: CRI 38910695
And the product team are looking into it. I’ll post here once I get any update about it.

 

Best Regards,
Herbert

Established Member
Status changed to: Accepted
 
Frequent Visitor

Hi Herbert,

 

May I ask how long this has been an issue and when we expect this to be resolved?

 

Thank You.

Super Contributor

@JoshuaHoward

 

I’ve got response from the Product Team.

 

In the most recent example, the Salesforce service is returning an HTTP 403, meaning "this account does not have permission to perform this operation". We don't know why Salesforce would return this error, and customers may need to contact Salesforce support to find out why.

 

Best Regards,
Herbert

Regular Visitor

I'm having problems with salesforce connections for quite a while. It's been about more than 7 months salesforce connections in different reports keep dropping and auto refresh keeps failing.

Everytime I need to check my refresh failure mail and reset the connection providing the same credential and it fails again on the very next refresh.

I do not know at which point it is failing, on salesforce or power bi gateway and cannot go through the log as well since the connection is direct.

I strongly hope Microsoft will focus in this issue.

 

Update: Yup, for past 2 days I am facing the exact same issue... No more login anymore and credential invalid error... 

 

- K3

Frequent Visitor

I too am having this issue. I am receiving an error that "The credentials provided for the Salesforce source are invalid." when they are not (Status: 400 error). I can sign into Salesforce online with the same credentials and connect to my reports from Power BI Desktop and refresh the datasets from there. I cannot sign in from Power BI Service. I have already spoken with Salesforce technical support and based on the login activity of Salesforce, the login from Power BI Service is successful. I am still getting the error on the Power BI Service side saying the credentials are incorrect (when they clearly are not). I hope this issue is fixed quickly.

Visitor

Having the same issue exactly - this needs a fix asap.

Moderator

Hi all,

 

I got information that it works if the account is an saleforce developer account. Please check which kind of Salesforce do you use? Thanks. 

 

Best Regards,
Qiuyun Yu 

 

Occasional Visitor

Hi,

 

I have the same issue; we have Salesforce Professional edition without API access. Refreshing in the online version of PowerBI does not work; however manual refresh on the desktop version of powerbi works fine.

 

PowerBI is a great tool to see business performance; but an automated update of data is essential in order to use it. As about 50% of our data is in Salesforce making this work would be of great value to us-- basically it's what stops adoption of PowerBI now as it can only function as a stand-alone tool, not as a way to keep the company informed.

 

 

 

Visitor

Same issue here, I can refresh the report through the desktop version, but not through app.powerbi.com. Any suggestion how to solve this annoying situation? Connecting directly to SalesForce. I also tried to use the security token together with my password, but that did not went through. Thanks in advance!

Nik