cancel
Showing results for 
Search instead for 
Did you mean: 

Salesforce data refresh with invalid credentials

Hi,

 

I've been experiencing an issue where I cannot refresh the dataset from the Saleforce data source in the Power BI service. While I am in Power BI desktop I am able to refresh the data without issue. While I am in the Power BI service, if I navigate to Settings > Datasets > Report Dataset Credentials, I am shown an error that tells me that the credetials are not correct. Even attempting to re-enter the credentials from this page does not allow the account to accomplish login.

 

First I select Settings > Datasets > Report.  You can see below the salesforce credentials are not working correctly.

 

1.jpg

 

I then click on edit credentials next to sales force and this is the pop up. OAuth2 is the only authentication method possible to select.

 

2.png

I click sign in and this pops up.  I then type in the username and password and click login.

 

3.png

After I click login I get this error that pops up.

 

4.png

 

The entered credentials are correct and should not return an issue.

Status: Accepted
Comments
Frequent Visitor

Any updates with this?

 

I'm surprised this hasn't been resolved yet. I would imagine fixing automatic refresh with Salesforce is a high priority.

Regular Visitor

After talking to both parties, salesforce and microsoft support; the only resolves I was able to find from microsoft were 

-use only one link per report, even if you are working with multiple tables, recreate the report fetching multiple tables at once (which is absurd for incremental reports).

-disable single sign on (which is another absurd idea because it might conflict company policy since this feature affects the entire salesforce users).

 

Luckily for me, we do not use SSO for my company and recreated the report fetching 3-4 tables all at once so that only one link is used this time rather than multiple; for me it is working however if it goes incremental, according to my previous experience, I can guarantee that issue will recur since no party guaranteed that the connector have been updated or so.

 

-K3

Visitor

We have the same issue - after a back and forth of calls and emails with MSFT & Salesforce, they came to the conclusion that the issue is using the Professional Edition of Salesforce.

New Member

I got the same issue today, 3/6/2019.   Get error when refresh data on Power BI service to Salesforce