cancel
Showing results for 
Search instead for 
Did you mean: 

SAP BW Publishing Issue

Hello,

I have created a report in PowerBI that uses data connected through SAP BW. When I refresh the report in the desktop app everything works fine. My numbers are showing correctly and all there is left to do is publish. When I publish the report I see the numbers matching but after anywhere from 2-5 minutes if I refresh the report or open it in a new window the report breaks and hardly any of my data shows up. All the while this is happening my numbers in the desktop version are still in tact. I have not had any issues refreshing the Desktop, just publishing the online version of the report. 

 

I initially thought it may have been some kind of boolean error or maybe my Sharepoint securities were messed up since I do have some excel files connected from Sharepoint. But later realized if I just throw the revenue (that comes straight from SAP) onto a table and publish, that only sums to 90% of my total revenue on the published screen. In sumary some of my data shows when publish but I'd say 90-95% of it does not.

 

Anything helps!

Status: Investigating

Perhaps you can consider and try that:

  1. If there are multiple measures and complex, which may affect the performance that you can try to optimize them
  2. If try to cut the data size or use a small part of the same data source to create the same report and publish to Power BI Service, whther the data can be wholly loaded and shown.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating

Perhaps you can consider and try that:

  1. If there are multiple measures and complex, which may affect the performance that you can try to optimize them
  2. If try to cut the data size or use a small part of the same data source to create the same report and publish to Power BI Service, whther the data can be wholly loaded and shown.

 

Best Regards,
Community Support Team _ Yingjie Li