Showing results for 
Search instead for 
Did you mean: 

Resolved! Issue to load PBIX connected to published DataSet in a Deployment Pipeline

Since last week, when I with Power BI Desktop opened my "thin" PBIX-files that are connected to published DataSets, they only partly completed the opening of the file:

  • In Report view (upper left icon) it showed a spinning load-symbol, no tables and no graphs.
  • In Model view (upper left below Report view icono) it showed all Tables and worked as usual. And tables could be dragged to the Layouts.


My suspicion was that it related to my test to assign this DataSet Workspace to a Deployment Pipeline.


Additional characteristics and what I tried:

  • Opening the thin PBIX never completed. At least not in several hours.
  • DataSource could'nt be changed in the thin PBIX, because it was busy loading. So I couldn't republish my DataSet PBIX to another/new WorkSpace. (Tough! I have multiple multi-page Reports from this DataSet.)
  • Creating a new thin PBIX from this DataSet worked! But I couldn't copy all my graphs and formatting from the once above that didn't open, and even if so it would be days of work.
  • I publish my thin PBIX-files in another WorkSpace/App than the DataSet.
  • Computer restarted.
  • August release of Power BI Desktop installed, but the problem occured with July release too.
  • This DataSet don't use Row Level Security.
  • This DataSet don't use Incremental Refresh, but another DataSet in the same WorkSpace do.
  • This DataSet do have a connection to another DataSet from another WorkSpace, with Import. (Some months ago, this relation used Direct Query, but to avoid the Preview limitation to require Build-access I changed to Import.)
  • I read about Limitations for Deployment Pipeline, Incremental Refresh, Composite models. 

But the solution was to remove the DataSet WorkSpace from the Deployment pipeline, and wait. As I was writing this post to ask for help it started to work. I think it is about 20 hours after I removed the WorkSpace from the Deployment pipeline. Puh!!! What a relief!


I'm good for now, but if anyone can more specifically explain what limitation kicked in it would be interesting to understand. Maybe it was my combinations of used features, and not Deployment Pipeline only.

Status: New
Frequent Visitor

Or maybe not... The issue came back.


- Anyone else with similar experience?


I shall not exclude that it in my case is something in the company IT infrastructure to cause the problem. Added delays of some added security feature or similar.

Frequent Visitor

Update: Occacionally the PBIX now opens, display all Page-tabes and empty graphs - but don't load data.


When it has come that far I can create new Page-tabs and in them new graphs - but data does not load anyway...

I can then also change DataSource settings to another copy of the DataSet, publicshed in a WorkSpace that has never been part of a Deployment Pipeline and from which new thin Reports can be easily made and works well. But it continues to spin, now with the blue spinner rarther than the b/w.


The original DataSet is large, but the Laptop's Task manager shows:

- 15-30% CPU usage

- 30% Memory usage


Still starts to look more and more like an issue with my Lapop, or with the company IT infrastructure/security/agents etc. that have caused issues before.


Comments most welcomed!

Community Support

Hi @MAHEswe ,

You have mentioned that the agents previously, have you tested this connection without the agent or contact your IT department to check whether it could be caused by the network(maybe) sometimes?


In addition, you coud refer:

  1. Report Data not working in TEST Pipeline Workspace 
  2. Deployment pipelines troubleshooting 


Best Regards,
Community Support Team _ Yingjie Li

Frequent Visitor

Thank you Yingjie Li for your comment.


The problem is most likely in our corporate IT infrastructure, not on the Microsoft side. Something is slow and makes something time-out.

It worked for some hours during the weekend, but then stopped working again.

I have now had the same problem to a DataSet that was never connected to a Deployment Pipeline, so it has nothing to do with Deployment Pipeline!


Finding the root cause could have been more easy to identify if PBI Desktop left a clear message like "Data was not possible to load because...", but that is nothing I suggest or request. The problem is most likely not on Microsoft/Power BI side. I'm ok with this report in this forum is closed.