Showing results for 
Search instead for 
Did you mean: 

Reports in power BI embedded suddenly stopped working

Our app has if, pre worked until yesterday
Today suddenly and without any modification it stopped working
ASP.NET application published on Azure with Power BI Embedded

Status: New
Not applicable

We are also facing same issue.

Not applicable

We are having the same issue as of this morning.

on the support page it says:

Starting 06/02/2020, Microsoft Power BI will begin rolling out to all regions enforcement of the TLS 1.2 protocol for all encrypted connections. All modern web browsers (Edge, Firefox, Chrome, Safari and Internet Explorer 11) support TLS 1.2. Any customers having connection issues should ensure they are using the latest web browser of their choosing. Any client/server connections (such as API/Embedded calls, Mobile apps etc) also must support TLS 1.2 in order to maintain connection to the Power BI service. For more information, please refer here

Has anyone managed to fix it yet? Not impressed that we weren't contacted directly about this!!!

Not applicable

Adding following line to the code worked for me.
System.Net.ServicePointManager.SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;

Regular Visitor

Thanks a lot sasi0467
it works for me too

Big work

Are you planning to take action for damages?

Not applicable

We don't have any action on damage as of now.

Advocate I

We faced the same issue. 400 bad request returned almost immediately when attempting to call a report.


Resolved in dev by adding the line provided by @Anonymous 

System.Net.ServicePointManager.SecurityProtocol |= SecurityProtocolType.Tls11 | SecurityProtocolType.Tls12;


Thank you!

Regular Visitor

Thanks  @sasi0467  ..worked for me  as well...struggled 28 hrs and found this ..